"No configuration method succeeded" but autoboot works



  • Hi everyone, no sure if this if this is an ipxe issue or a FOG issue: I am attempting to boot into FOG using ipxe.

    The computer netboots, pulls the ipxe image, and then is supposed to boot into FOG, but it fails with “No configuration methods succeeded” and the 040ee119 error. ifstat shows closed. However, if I use the dhcp command, it returns “ok” and then ifstat returns open. From here, running autoboot boots into FOG as expected.

    So my question is, why doesn’t this happen automatically?

    Placing a dumb switch in between the computer and the network stack, makes the netboot go automatically. I have read that disabling EEE on the switch (Cisco 2690S) can fix this, but the switch does not support EEE.

    I am out of my element as far as networking goes, so I am unsure how to troubleshoot.


  • Moderator

    @f-15s-mtd You will need to change every switch/port that has a device that you want to pxe boot on. This is an access layer issue not something related to the FOG server or switch to switch communication. The problem is in the “last mile” so to speak.

    ref: https://community.cisco.com/t5/other-network-architecture/enable-portfast-on-all-ports/td-p/324511 read down the post because there are switch global commands that you can use.



  • Awesome, changing protocols is actually on the big to-do list anyway.

    For the sake of testing, would I only need to change the switches in the route, or would every switch need to be changed (it’s a good size network)?

    Thank you!


  • Moderator

    ok since you tested with a cheap/dumb/unmanaged switch and it works, then the problem is most likely that you have standard spanning tree enabled on your network switch. You need to change the configuration so you are using one of the fast spanning tree protocols (port-fast, FastSTP, RSTP, MSTP, or what ever your switch manufacturer calls it).


Log in to reply
 

290
Online

7.4k
Users

14.5k
Topics

136.6k
Posts