SOLVED UEFI Boot dosent work with some Lenovo Thinkpad Models

  • Hello i have a Problem with my FOG or DHCP.
    Essentialy we have mostly Lenovo for our Notebooks the imaging and deploying Process works fine, but in some cases the Notebook will boot in pxe successfuly downloads the NBP file and then it runs into Error DHCP failed.

    We are using a Windwos Server 2012 as DHCP with both Legacy and UEFI boot settings.
    For Uefi Boot we are using intel.efi and for Legacy …

    The Fog Server is a Cent OS 7.2 install.

    It is not a specific Notebookmodel it ist sometimes a P53 or a T15, strangely if you change it to Legacy it boots normaly into the FOG and you can Deploy an Image. Also it gets the IP from the Server correctly and everything seems normal until it runs into the DHCP error.

    Thanks for Replays in Advance!

  • @george1421 So actually we testet the ipxe.efi boot file and it Resolved the Error that we had. So thanks for the Help and Support, i hope it will stay so 🙂

  • Yes i tried it already we actually have now 2 unmanged Network Switches between the target Computer and the Building Network Switch. But normaly we also use the Fast Spanning Tree Protocoll.

  • Moderator

    @Nick As for the picture. Do you have a dumb/unmanaged/super cheap network switch you can place between the target computer and the building network switch. My first reaction is this is a spanning tree issue, where the building switch isn’t using one of the fast spanning tree protocols. A super cheap switch will mask this issue and help us diagnose the issue.

  • Thanks fo the Response.

    We have only intel nic’s in the Notebooks so it worked fine so far for most of the Notebooks, but i will change it into ipxe.efi and i will test it.

    Secondly i would like to Upload a Picture but i get a Error Message after the upload that something with installing the “sharp” module went wrong.
    So i uploaded it now to imgur i hope this helps.

  • Moderator

    Well two things jump out at me from your description.

    First what happens if the network adapter isn’t an intel nic? There are a lot of systems that have realtek network adapters. I think I would use the ipxe.efi instead. That has all of the drivers built in.

    The second thing is where is the error in the booting process? Having a picture of the error when it doesn’t boot would give us the context where to look.