No network interfaces found when deploying Image

  • Hello everyone,

    I am having an issue that when I want to deploy an image to a Lenovo X1 Carbon 7th Gen (20R1) an error comes up telling me No network interfaces found, your kernel is most probably missing the correct driver!

    However, I just imaged a Lenovo P43s (20RH) and another Lenovo X1 Carbon 7th Gen (20QD) and both were imaged just fine. Same cable, same Lenovo adapter, same port, same switch and same VLAN. Same steps for prepping bios before the image as well, which are disabling Kernel DMA Protection, Disabling Secure Boot, Startup I choos Both and Legacy First and on the Boot order I put PXE first. I am running FOG 1.5.5.

    I did try another X1 (20R1) and I get the same error. I updated the bios and the network drivers and ran all the Lenovo Vantage updates after getting the error the first time. I also removed Bitlocker encryption, turned off fast boot and nothing has fixed the issue. So I imagine the problem it’s with this specific model of X1s (20R1).

    Has anyone encountered this? Any suggestions?

    Thank you in advance.

  • Moderator

    @sysadmin How did you create this directory /opt/fog_stable Did you clone it from the git repository? Your error is not a very common one or one I’ve personally seen before.

  • @george1421 I assume that the only way to repair this is to reinstall Fog. I am not sure where to start to do this manually. Any pointers?

  • @george1421 morning. Yesterday I started on this. When I got to step 8 it seems I installed Fog here /opt/fog_stable/bin/

    I get the following error. I don’t recall ever getting this message.

    root@fog2:~# /opt/fog_stable/bin/
     * Are you sure you wish to continue (Y/N) Y
     * Installation Started
     * Installing required packages, if this fails
     | make sure you have an active internet connection.
    /opt/fog_stable/bin/ line 517: installPackages: command not found
     * Confirming package installation
    /opt/fog_stable/bin/ line 521: confirmPackageInstallation: command not found
     * Configuring services

  • @george1421 Thank you for your help. I’ll continue with this tomorrow. I have to run some errands and eat something, I’ve been at it for a couple of hours. 🙂 Thanks again.

  • Moderator

    @sysadmin Ok this is going to be a problem once we get past the kernel issue, but that explains why the network adpater isn’t working, simply because linux 4.19.x doesn’t have a valid driver installed.

    To address the FTP password problem, follow this tutorial:

    Something seems to have gotten out of place.

    If this doesn’t work we can always download the kernel manually, but as I said you will run into an issue on the next image capture you do.

  • @george1421 It seems I have 4.19.123 x86_64. However when I ran the script I thought I updated.

    If I try to update through the FOG GUI I get this error. Not sure what credentials I should be using under TFTP Server.

    Type: 2, File: /var/www/html/fog/lib/fog/fogftp.class.php, Line: 464, Message: ftp_login(): Login incorrect., Host:, Username: fog

  • Moderator

    @sysadmin said in No network interfaces found when deploying Image:


    Interesting that device comes back to
    vendor: 8086 (“Intel Corporation”), device: 0d4f (“Ethernet Connection (10) I219-V”)

    First introduced into the linux kernel 5.5. You should have downloaded and installed 5.6.7 of the FOS Linux kernel, that should have worked.

    From the FOS Linux console, key in uname -a It should print out a version number. Is that version number 5.5 or later?

    I can see from the ip a command that the driver for that network adapter isn’t loaded. Lets confirm the version of the kernel that is running. If you still have the 4.19.x series then I understand why its not working.

  • @george1421

    So I get this. Hope it helps.

    ip addr show
    1: lo: <LOOPBACK, UP, LOWER_UP> mtu 65536 qdisc noqueue qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet /8 scope host lo
    valid_lft forever preferred_lft forever

    lspci -nn | grep -i net
    00:14.3 Network controller [0280]: Interl Corporation Device [8086:02f0]
    00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (10) I219-v [8086:0d4f]

    For the hardware ID there were 4 values in there under device manager.

  • Moderator

    @sysadmin Boy that amazon picture is so bad I can’t tell (visually) what that connector is. From searching the text it appears to be a lenovo unique cable that just extends the build in network adapter wires to an external rj45 jack.

  • Moderator

    @sysadmin OK then step 2.

    If you have a running windows computer on this hardware, go into the device manager and get the hardware ID of this NIC. It will be in the form of VEND and DEV.


    Reschedule a capture/deploy to this computer (doesn’t matter which) but before you hit the submit task button, tick the debug checkbox then submit the task. Note: If you did not get to registering this computer go ahead and manually register it with the mac address of the nic interface on this computer

    PXE boot the target computer, after a few screens of text that you will need to clear by pressing the enter key you will be dropped to the FOS Linux command prompt. At that command prompt key in and post the results of the following.

    ip addr show

    lspci -nn | grep -i net

    So this network adapter works on other models just not this specific model [Lenovo X1 Carbon 7th Gen (20R1) ]? I’m assuming its either USB or USB-C attached?

    Keep the debug console up because there may be other commands you will need to type in.

  • Hi @george1421, I guess I was doing this while you were typing your response. I updated the Kernel using the manual method with the script from this part of the wiki I updated sucessfully.

    RAMDISK: incomplete write (-28 !=4096) - After the update I got this error, but I modified the KERNEL RAMDISK SIZE to 275000 and now I am back at No network interfaces found… but this time there’s less error messages on my screen now.

    Starting syslogd: OK
    Starting klogd: OK
    Running sysctl: OK
    Populating /dev using udev: done
    Saving random seed: OK
    Starting haveged: haveged: listeningsocket at 3 OK
    No network interfaces found, your kernel is most probably missing the correct driver!
    Please check your network setup and try again!

    After I press Enter

    Init Version: 20200517

  • Moderator

    @sysadmin Ok here is specifically what I want you to do.

    On the FOG server web ui go to FOG Configuration-> Kernel update. First note your current version of the FOS Linux kernel, then update to the version 5.x release of the kernel. Once you have updated to version 5.6.x go ahead and pxe boot the target computer and see if it picks up an IP address then.