Clamav version update


  • Developer

    Hi,

    How can I update the clamav version?

    The version of clamav in init.gz is 0.96 and is obsolete. When you run a antivirus task appears a warning: "Version OUTDATED!!! ".
    The release version of clamav is 0.97.6.


  • Senior Developer

    Though its slightly aged have you gotten this figured out? I suppose a little research could be done but I think you could do:
    apt-get build-dep build root
    But don’t quote me as I don’t use Debian based OS.
    If you need help I’ll try where I can.



  • now I have done apt-get install libicu48 based on above.

    I am looking for expertise that can show where I am going wrong. It seems I am stepping through error by error.



  • I did this and getting closer. Can someone help get this finished?
    apt-get install pkg-config
    apt-get update
    apt-get upgrade

    Now I get the following:

    rm /Temp/NewInit/buildroot-2011.08/output/build/buildroot-config/zconf.tab.c
    make[1]: Leaving directory `/Temp/NewInit/buildroot-2011.08/package/config’
    Unable to load library icui18n "Cannot load library icui18n: (libicui18n.so.48: cannot open shared object file: No such file or directory)"
    qconf: cannot connect to X server
    make: *** [[B]xconfig] Error 1[/B]



  • I used echo export QTDIR=/usr/share/qt4 >> ~/.bashrc
    and can see QTDIR=/usr/share/qt4 when I use env
    and get the same text errors above



  • Hello,

    Heres what I have completed based on the wiki - [url]http://www.fogproject.org/wiki/index.php/Build_FOG_file_system_with_BuildRoot_-_init.gz[/url] - and your notes above. I am getting the errors listed using the CLI, no GUI used. I am using Ubuntu 12.04.2 server LTS 64bit and FOG 0.32 and ClamAV 0.97.6. I have searched and found different recommendations but checking to see if you know exact problem.

    Can you help me get past this error? Thanks again.

    1 - update Ubuntu
    apt-get update
    apt-get upgrade
    apt-get install build-essential subversion libqt4-dev bison flex gettext texinfo zlib1g-dev uuid-dev
    2 - download the FOG source
    cd /
    cd Temp
    mkdir NewInit
    mkdir NewInit/svn
    cd NewInit/svn
    svn checkout [url]https://freeghost.svn.sourceforge.net/svnroot/freeghost/trunk[/url]
    You should get a checked version XXXX. As of 28 Feb 13 it is 898.
    3 - download Buildroot
    cd …
    wget [url]http://buildroot.uclibc.org/downloads/buildroot-2011.08.tar.gz[/url]
    tar xvfz buildroot-2011.08.tar.gz
    3a - The change for ClamAV
    nano svn/trunk/src/buildroot/package/customize/clamav/clamav.mk
    change CLAMAV_VERSION:=0.97.1 to CLAMAV_VERSION:=0.97.6
    remove the last / from CLAMAV_SITE:=[url]http://[/url]…
    4 - copy source to Buildroot
    cp -rf svn/trunk/src/buildroot/* buildroot-2011.08/
    cd buildroot-2011.08
    mv fog.buildroot.config .config
    5 - build FOG file system
    make xconfig
    then

    mkdir -p /Temp/NewInit/buildroot-2011.08/output/build/buildroot-config/lxdialog
    make CC="/usr/bin/gcc" HOSTCC="/usr/bin/gcc" obj=/Temp/NewInit/buildroot-2011.08/output/build/buildroot-config -C package/config -f Makefile.br qconf
    make[1]: Entering directory `/Temp/NewInit/buildroot-2011.08/package/config’
    /usr/bin/gcc -DCURSES_LOC="<curses.h>" -DLOCALE -I/Temp/NewInit/buildroot-2011.08/output/build/buildroot-config -MM *.c > /Temp/NewInit/buildroot-2011.08/output/build/buildroot-config/.depend 2>/dev/null || :
    CHECK qt

    • [B]Unable to find the QT4 tool qmake. Trying to use QT3[/B]
    • [B]Unable to find any QT installation. Please make sure that[/B]
      [B]* the QT4 or QT3 development package is correctly installed[/B] and
    • either qmake can be found or install pkg-config or set
    • the QTDIR environment variable to the correct location.

    make[1]: Leaving directory /Temp/NewInit/buildroot-2011.08/package/config' make[1]: Entering directory/Temp/NewInit/buildroot-2011.08/package/config’
    CHECK qt

    • Unable to find the QT4 tool qmake. Trying to use QT3
    • Unable to find any QT installation. Please make sure that
    • the QT4 or QT3 development package is correctly installed and
    • either qmake can be found or install pkg-config or set
    • the QTDIR environment variable to the correct location.

    make[1]: *** No rule to make target /Temp/NewInit/buildroot-2011.08/output/build/buildroot-config/.tmp_qtcheck', needed by/Temp/NewInit/buildroot-2011.08/output/build/buildroot-config/qconf.o’. Stop.
    make[1]: Leaving directory `/Temp/NewInit/buildroot-2011.08/package/config’
    make: *** [/Temp/NewInit/buildroot-2011.08/output/build/buildroot-config/qconf][B] Error 2[/B]


  • Developer

    Well, at last I make it :) I have clamav 0.97.6 installed in my init.gz.
    I have remade my init.gz usinig builtroot (see[SIZE=3] [URL=‘http://www.fogproject.org/wiki/index.php/Build_FOG_file_system_with_BuildRoot_-_init.gz’]Build FOG file system with BuildRoot - init.gz[/URL][/SIZE] [1])
    But you need make one change in file …/buildroot-2011.08/package/customize/clamav/clamav.mk
    You must change [B]CLAMAV_VERSION=0.97.6[/B]

    [CODE]#############################################################

    clamav

    #############################################################
    CLAMAV_VERSION:=0.97.6
    CLAMAV_SOURCE:=clamav-$(CLAMAV_VERSION).tar.gz
    CLAMAV_SITE:=http://downloads.sourceforge.net/project/clamav/clamav/$(CLAMAV_VERSION)
    CLAMAV_INSTALL_STAGING=YES
    CLAMAV_LIBTOOL_PATCH=NO
    CLAMAV_CONF_OPT= --disable-clamav
    –enable-clamdtop=no
    –disable-clamuko
    –enable-check=no
    –enable-llvm=no
    –program-transform-name=
    CLAMAV_DEPENDENCIES=zlib bzip2

    define CLAMAV_REMOVE_DB
    rm -f $(TARGET_DIR)/usr/share/clamav/*.cvd
    endef

    define CLAMAV_SIMPLE_CONFIG
    echo “DatabaseMirror database.clamav.net” > $(TARGET_DIR)/etc/freshclam.conf
    echo “DatabaseOwner root” >> $(TARGET_DIR)/etc/freshclam.conf
    endef

    CLAMAV_POST_INSTALL_TARGET_HOOKS += CLAMAV_REMOVE_DB
    CLAMAV_POST_INSTALL_TARGET_HOOKS += CLAMAV_SIMPLE_CONFIG

    $(eval $(call AUTOTARGETS,package/customize,clamav))[/CODE]

    Also you have erase the “/” in line:

    [QUOTE]Old line:
    CLAMAV_SITE:=[url]http://downloads.sourceforge.net/project/clamav/clamav/$(CLAMAV_VERSION)/[/url]
    New line:
    CLAMAV_SITE:=[url]http://downloads.sourceforge.net/project/clamav/clamav/$(CLAMAV_VERSION)[/url]
    [/QUOTE]

    [1] [url]http://www.fogproject.org/wiki/index.php/Build_FOG_file_system_with_BuildRoot_-_init.gz[/url]


  • Developer

    Thanks for information :) , but I want to update the clamscan in the client side.



  • I found this link that may be helpful as I am about to do the same thing due to a nasty virus infection. Will keep you posted.

    [url]http://www.fogproject.org/wiki/index.php/Clamav[/url]


Log in to reply
 

354
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.