NBP file downloaded succesfully



  • Hi everybody, i update a fog 1.5.7 to a 1.5.8 on debian 8.
    Before update, i can boot on pxe with the “fujitsu esprimo g558”; but after update i have only this message “NBP file downloaded succesfully” and i return to the boot selection. Thats’ all.
    I have a uefi network boot only in bios options. I tried update bios…
    The others models works with update. What is the problem with esprimo g558 based on a “realtek uefi undi driver 2.0.40”?
    I tried to change for a older kernel in fog but nothing at all.
    A subject like this was opened in 2018 but i didn’t find a answer.
    Is there a solution or it will be fixed in next versions?



  • @Sebastian-Roth I search for " realtek undi driver" for fog in google and i found a page in the forum with this link in the tftp in the 1.4.4 section.
    It was missing in the 1.5.8. i just add it.



  • i let the 1.5.8 binaries in /tftpboot except i had only the “ipxe7156.efi” file. I was obliged to rerun the installation script because the file “ipxe7156.efi” had not the right group permissions.


  • Senior Developer

    @cyrmoon said in NBP file downloaded succesfully:

    i downloaded from “https://github.com/FOGProject/fogproject/tree/1.4.4/packages/tftp” the “ipxe7156.efi” , i put it in /tftpboot; i rerun the install fog script and it seems to work.

    This seems to reverse the logic a bit. iPXE binaries you put into /tftpboot are in the correct place. If you re-run the installer after that you will have those in /tftpboot being overwritten again by whatever installer you have.

    By the way, why did you use the way older 1.4.4 binaries??



  • @cyrmoon I tried to apply this solution, i created three policy in the ipv4 dhcp scope:

    • “PXEClient:Arch:00002” and “PXEClient:Arch:00006” both should get “i386-efi/ipxe.efi” as their option 067 boot file.

    “PXEClient:Arch:00008”, “PXEClient:Arch:00009”, and “PXEClient:Arch:00007” should get “ipxe.efi” as their option 067 boot file.

    “PXEClient:Arch:00007:UNDI:003016” should get “ipxe7156.efi” this file is specific to the Surface Pro 4.

    i downloaded from “https://github.com/FOGProject/fogproject/tree/1.4.4/packages/tftp” the “ipxe7156.efi” , i put it in /tftpboot; i rerun the install fog script and it seems to work.

    What do u think about it? a reliable solution or a future problem?


  • Moderator

    @cyrmoon Sounds like you need to configure your DHCP server to handle UEFI clients.

    The Wiki article you listed has a section for windows server DHCP. Give it a try.



  • I used not fog in a dhcp server, i used a server 2016 for dhcp with option 66 and 67.
    I always used the fog menu , i saw it before update, and on others models i see it too.
    I delete all in the “tftpboot” on the fog server and replace with all binaries in the link u gave me.
    I tried but it’s the same; maybe the problem came from my windows dhcp server.
    I change for a window server 2016 dhcp and the others models boot with undionly.kpxe. (the g558 esprimo have only uefi boot)
    The uefi bios boot with ipxe.efi?
    i found a fog doc here. “https://wiki.fogproject.org/wiki/index.php/BIOS_and_UEFI_Co-Existence” Thats is a solution?


  • Senior Developer

    @cyrmoon said in NBP file downloaded succesfully:

    I tried to change for a older kernel in fog but nothing at all.

    This issues seems to be caused by iPXE not the Linux kernel we use in FOS to do the actual imaging.

    Is there a solution or it will be fixed in next versions?

    FOG is open source and so we rely on people like you to test things and let us know what works and what not. We don’t have all the hardware to test on our own.

    So let’s get into this and see what is actually causing the failure after “NBP file downloaded succesfully”. Before you updated from 1.5.7 did you see the FOG boot menu after the “NBP file downloaded succesfully”? I just want to make sure we hunt down the right path. I am asking because you can setup FOG to hide the menu and just run a default menu item. If that is the case we’d need to look further than iPXE…

    Here is the code tree of FOG 1.5.7 iPXE binaries. Just download the iPXE binary that you are using in you DHCP server and put that in /tftpboot directory on your FOG server. See if the fujitsu esprimo g558 works correctly again.


Log in to reply
 

283
Online

7.4k
Users

14.5k
Topics

136.5k
Posts