Capturing image keep failing at database update


  • Testers

    Hello,
    I am using CentOS 7.5 with 1.5.8 fog installed. It is keep failing to update the database after capture
    It has two Ethernet port. enp0s31f6 to only manage for administrative purpose. p3p2 is to provide dhcp and all fog related data transmission
    test.jpg


  • Developer

    @msi I am wondering why you have two IP addresses within the same subnet assigned to your FOG server? Any good reason to do this?

    I also noticed that it is using enp0s31f6 IP address instead of p2p3 IP (192.168.1.230). is it normal since both IP’s are working when accessing the web console?

    FOS uses the IP set as FOG_WEB_HOST (FOG Configuration) to call out to the FOG webserver. I suppose you have set 192.168.1.230 in that field, right? That shouldn’t matter from my point of view.

    If you have checked all the passwords and resynced as described by George I may ask you to do a simple FTP test: https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_FTP


  • Testers

    @Sebastian-Roth we are using p3p2. I just rechecked, all are using p3p2 interface in the web ui

    [root@gaaufog php-fpm]# ip a s
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    2: p3p1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 00:13:3b:12:30:f3 brd ff:ff:ff:ff:ff:ff
    3: p3p2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 00:13:3b:12:30:f4 brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.230/24 brd 192.168.1.255 scope global noprefixroute p3p2
           valid_lft forever preferred_lft forever
        inet6 fe80::ec94:a6b:f680:c6d5/64 scope link noprefixroute
           valid_lft forever preferred_lft forever
    4: enp0s31f6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 54:bf:64:85:96:1d brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.104/24 brd 192.168.1.255 scope global noprefixroute dynamic enp0s31f6
           valid_lft 20999sec preferred_lft 20999sec
        inet6 fe80::ae81:cd39:7f04:8cd1/64 scope link noprefixroute
           valid_lft forever preferred_lft forever
    5: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
        link/ether 52:54:00:13:1e:25 brd ff:ff:ff:ff:ff:ff
        inet 192.168.122.1/24 brd 192.168.1.255 scope global virbr0
           valid_lft forever preferred_lft forever
    6: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast master virbr0 state DOWN group default qlen 1000
        link/ether 52:54:00:13:1e:25 brd ff:ff:ff:ff:ff:ff
    
    [root@gaaufog php-fpm]# ip r s
    default via 192.168.1.250 dev enp0s31f6 proto dhcp metric 104
    default via 192.168.1.250 dev p3p2 proto static metric 105
    192.168.1.0/24 dev enp0s31f6 proto kernel scope link src 192.168.1.104 metric 104
    192.168.1.0/24 dev p3p2 proto kernel scope link src 192.168.1.230 metric 105
    192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1
    [root@gaaufog php-fpm]#
    

    test.jpg


  • Developer

    @msi Well we don’t know your interfaces and settings. Please run ip a s as well as ip r s and post output here. As well take a picture of the storage node settings in the web UI and check all the FOG Configuration -> FOG Settings stuff to see if it uses the correct interface. Which interface did you tell FOG to use when installing? You might edit /opt/fog/.fogsettings as well just to make sure it’s not messing up things again when you re-run the installer.


  • Testers

    @Sebastian-Roth I just checked all. All passwords are matching but still not working. I also noticed that it is using enp0s31f6 IP address instead of p2p3 IP (192.168.1.230). is it normal since both IP’s are working when accessing the web console?


  • Testers

    This post is deleted!

  • Developer


  • Testers

    Looks like ftp password is mismatching as below screenshottest.jpg


  • Developer

    @msi What do your get in the apche and/or PHP-FPM logs (see my signature)??

    As the client seems to be able to check in to that task I don’t think it’s a general issue with the webserver per se.


Log in to reply
 

326
Online

6.8k
Users

14.1k
Topics

133.4k
Posts