Sysprep.exe Help



  • Having a slight problem over here, I have built my answer file and got windows 7 to image fully, but every time i start the computer it says preparing computer for first use then auto logs into the local admin account and brings up the system preparation tool 3.14. I’ve tried the options to quit and oobe then reboot but it always seems to come back. Any Ideas?

    Could this a problem with my answer file telling it to run again?

    I have tried looking in the start up folder, Using Autoruns, and checking msconfig for entries to run sysprep on start up but have found nothing so far.


  • Developer

    you do not need to specify the Reseal in your xml file as that’s what the switches do - by having this in your unattend file it conflicts with the switches you pass to sysprep. just remove this section all together from your unattend file and it should stop the issue.



  • I think it has something to do with reseal mode lines in my XML file

    <settings pass=“oobeSystem”>
    <component name=“Microsoft-Windows-Deployment” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm="[url]http://schemas.microsoft.com/WMIConfig/2002/State[/url]" xmlns:xsi="[url]http://www.w3.org/2001/XMLSchema-instance[/url]">
    <Reseal>
    <Mode>[COLOR=#ff0000]audit[/COLOR]</Mode>
    </Reseal>

    I think that audit should be something else. But I’m not sure what goes there? I Tried oobe but it tells me that its out of range and can’t process it.

    Sorry about the bad formatting



  • I’ve done it both in audit mode and normal mode without issues, like chad-bisd, i always used the /oobe /generalize /unattend switches.



  • I wonder if it is coming back up all the time due to the fact I wasn’t in audit mode when I ran it before uploading my Image, I just tried running it in audit mode before hand and its uploading as I’m typing this, I’ll report back when I image a computer with it.


  • Moderator

    The only times I’ve used sysprep are with the /oobe /generalize /unattend options. I have not had issues with it coming back up after a reboot unless I used the /audit pass flag.

    Sysprep is a monster and I quit trying to fight the monster as soon as I got what I needed. I hope some others on the forums can help.


Log in to reply
 

370
Online

38983
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.