Interface not ready, waiting for it to come up



  • Hi,
    Since i have upgrade to 1.5.8 i have problem with multicast and fogscheduler.

    In all my logs file (fogscheduler.log, multicast.log etc) i have this line repaeted :

    Interface not ready, waiting for it to come up: mydomain.fr
    

    I have verify this :
    -ip addr show => eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    -Fog Configuration -> Fog Settings -> Multicast settings -> UPDCAST INTERFACE => eth0
    -Storage -> Default storage node -> Interface => eth0

    I have try to reboot my server.

    Have you idea ?



  • @Sebastian-Roth It’s just started working now, thank you for your support!



  • @Sebastian-Roth Hi, thank you for your help so far but no, we are now back to having the IP address tagged on the end now:

    Interface not ready, waiting for it to come up: 10.101.15.2

    If it helps both servers are running Ubuntu 18.04.4 and I have done the fix you gave to both servers as well as both have been restarted


  • Senior Developer

    @lewisreid01 said in Interface not ready, waiting for it to come up:

    I have tried that, it gives me the same error just without the IP address on the end:

    Done it on the storage node for sure?

    Try rebooting the storage node then.

    If that doesn’t help, please take pictures of your “storage” nodes’ settings (all of them, master as well as storage) and post here.



  • Well, I feel stupid right now. I seemed to restart the services on the wrong server because when I restarted all the FOG services on both on my Node and Storage, the errors in the logs dissapeared. Even did a test multicast session, started imaging right away with WOL and PXE. So marking solved on my part.



  • @george1421 Both are Debian 10 (buster) x86_64 GNU/Linux.


  • Moderator

    @Kanja For some data collection, what OS is the fog server is running on? (mfg and version)



  • Adding myself to the list as another victim. The same error appeared after upgrading to 1.5.8. Now at 1.5.8.5 (dev-branch) and the error is exactly the same as @lewisreid01 mentioned with no IP address in the end. I have 1 node and 1 storage where the separate storage is the master and only storage. Didn’t change my configuration file after upgrade.



  • Hi,

    I have tried that, it gives me the same error just without the IP address on the end:

    Interface not ready, waiting for it to come up:

    Any other ideas?


  • Senior Developer

    @lewisreid01 said:

    I would be more than happy to give it a go, how do I get it?

    Easiest would be to just get the latest copy of that fixed file and restart the services:

    sudo -i
    cd /var/www/html/fog/lib/service/
    wget -O fogservice.class.php https://raw.githubusercontent.com/FOGProject/fogproject/8bb1397e7006fa7dd455de0214766165ed8e3db2/packages/web/lib/service/fogservice.class.php
    cd /lib/systemd/system
    # or /usr/lib/systemd/system if you use CentOS/RedHat
    wget -O FOGSnapinReplicator.service https://raw.githubusercontent.com/FOGProject/fogproject/8bb1397e7006fa7dd455de0214766165ed8e3db2/packages/systemd/FOGSnapinReplicator.service
    cd
    systemctl daemon-reload
    systemctl restart FOGImageReplicator.service
    systemctl restart FOGImageSize.service
    systemctl restart FOGMulticastManager.service
    systemctl restart FOGPingHosts.service
    systemctl restart FOGScheduler.service
    systemctl restart FOGSnapinHash.service
    systemctl restart FOGSnapinReplicator.service
    


  • @Sebastian-Roth I would be more than happy to give it a go, how do I get it?


  • Senior Developer

    @lewisreid01 @Florent Thanks for bringing this up. I had a look at the code just now a found there to be a bug. Just pushed a fix to dev-branch. Keen to test?



  • @Sebastian-Roth That is the IP of the main server


  • Senior Developer

    @lewisreid01 said in Interface not ready, waiting for it to come up:

    Interface not ready, waiting for it to come up: 10.101.15.2

    Is this the IP of your storage node?



  • Hi,

    I am having the same issue, I have tried the fix mentioned by Florent about the Web Host setting but it hasn’t changed anything. Could anyone help me? It has only happened since the update. Both the main server and storage node have internet and local network access and can ping each other, but these errors are being shown in all the service logs on the storage node:

    Interface not ready, waiting for it to come up: 10.101.15.2

    I have tried rebuilding the storage server and nothing has changed, has anyone got any ideas?

    Thanks a lot
    Lewis



  • Sorry i have found the problem.
    In FOG Settings / Web Server / Web Host i have set the same result of cat /etc/hostname

    Because before i have here an network alias.

    Regards.



  • This not resolve for me 😞
    All my FOG* service are Active: active (running) correctly
    Upload and download image work.
    Just schedule tasks (for example wakeonlan with cron) and multicast not work.



  • i had the same problem with replication serice. My fix for centos7 :

    code_text
    systemctl restart FOGImageReplicator
    systemctl status FOGImageReplicator
    
    Of course u have to change the "FOGImageReplicator" to whatever service is bugging you and then check it out with 
    
    tail -f /var/log/fog/log/fogreplicator.log

Log in to reply
 

307
Online

7.4k
Users

14.5k
Topics

136.6k
Posts