Interface not ready, waiting for it to come up



  • [root@fognode ~]# tail -f /var/log/fog/fogreplicator.log
    [02-21-20 3:43:38 pm] Interface not ready, waiting for it to come up: 192.168.192.111
    [02-21-20 3:43:48 pm] Interface not ready, waiting for it to come up: 192.168.192.111
    [02-21-20 3:43:58 pm] Interface not ready, waiting for it to come up: 192.168.192.111
    [02-21-20 3:44:08 pm] Interface not ready, waiting for it to come up: 192.168.192.111
    [02-21-20 3:44:18 pm] Interface not ready, waiting for it to come up: 192.168.192.111
    [02-21-20 3:44:28 pm] Interface not ready, waiting for it to come up: 192.168.192.111
    [02-21-20 3:44:38 pm] Interface not ready, waiting for it to come up: 192.168.192.111
    [02-21-20 3:44:48 pm] Interface not ready, waiting for it to come up: 192.168.192.111
    [02-21-20 3:44:58 pm] Interface not ready, waiting for it to come up: 192.168.192.111
    [02-21-20 3:45:08 pm] Interface not ready, waiting for it to come up: 192.168.192.111

    …now why is this showing up now ?

    Fog 1.5.8
    Master Fog and Node IP 111 Interface eth0
    Fog Node IP 114 Interface ens160
    …what more should i provide ?


  • Moderator

    @AlexPDX So if you look on the storage node(s), are those image files there?



  • Ok so i’v managed to get things working ( edited the interface in Fog Storage and Multicast )
    now what do i have to do so what ALL my images from Master Node to be replicated to the Storage Node ?
    now i got this … :

    [root@HQ-FOG fog]# tail -f /var/log/fog/log/fogreplicator.log
    [02-24-20 2:54:53 pm]  | Image Name: Win10x64MBR-Default
    [02-24-20 2:54:54 pm]   # Win10x64MBR-Default: No need to sync d1.fixed_size_partitions (Server_114)
    [02-24-20 2:54:54 pm]   # Win10x64MBR-Default: No need to sync d1.mbr (Server_114)
    [02-24-20 2:54:54 pm]   # Win10x64MBR-Default: No need to sync d1.minimum.partitions (Server_114)
    [02-24-20 2:54:54 pm]   # Win10x64MBR-Default: No need to sync d1.original.fstypes (Server_114)
    [02-24-20 2:54:54 pm]   # Win10x64MBR-Default: No need to sync d1.original.swapuuids (Server_114)
    [02-24-20 2:54:54 pm]   # Win10x64MBR-Default: No need to sync d1.partitions (Server_114)
    [02-24-20 2:54:55 pm]   # Win10x64MBR-Default: No need to sync d1p1.img (Server_114)
    [02-24-20 2:54:55 pm]   # Win10x64MBR-Default: No need to sync d1p2.img (Server_114)
    [02-24-20 2:54:55 pm]  * All files synced for this item.
    

    I have 1 Gropu with 1 Master Node (111) and 1 Storage Node (114)
    …can i just copy > paste( or transfer via FTP) the folders with images name from Master Node to Storage Node…or this should be done automaticly ?


  • Moderator

    @AlexPDX The interface needs to be named right under the fog configuration setting as well as in the storage node definition. I’m not saying this is the root of your problem, just if the value isn’t right on the master node it might throw that error about the interface not ready.



  • @george1421 said in Interface not ready, waiting for it to come up:

    @AlexPDX said in Interface not ready, waiting for it to come up:

    “ens160” … Master Storage has “eth0” interface

    The value eth0 is wrong. The values need to match the physical names of the interfaces installed. In the case of the master node this value needs to be ens160.

    Ok 10x i will change this now in Master Node and come back with a log from Master Node 111
    …the logs from early wore from Storage Node 114


  • Moderator

    @AlexPDX said in Interface not ready, waiting for it to come up:

    “ens160” … Master Storage has “eth0” interface

    The value eth0 is wrong. The values need to match the physical names of the interfaces installed. In the case of the master node this value needs to be ens160.


  • Senior Developer

    @AlexPDX said in Interface not ready, waiting for it to come up:

    [root@fognode ~]# tail -f /var/log/fog/fogreplicator.log
    [02-21-20 3:43:38 pm] Interface not ready, waiting for it to come up: 192.168.192.111
    

    I am still not sure I get this right. You seem to use the term “FOG node” for your FOG storage node (IP 114). That is why I said you can ignore this log on the storage node. Replication only happens from master to storage initiated by the master and no real interaction on the storage node side - more or less just receives the data via FTP.

    So please tell us where you see this log?

    As well you might tell us if there is anything not working or if you are just concerned about the logging entries!



  • @george1421 said in Interface not ready, waiting for it to come up:

    On your fog server, what is the output of this command ip addr show

    [root@fognode ~]# ip addr show
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: ens160: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:50:56:9d:44:74 brd ff:ff:ff:ff:ff:ff
    inet 192.168.192.114/24 brd 192.168.192.255 scope global noprefixroute ens160
    valid_lft forever preferred_lft forever
    inet6 fe80::250:56ff:fe9d:4474/64 scope link
    valid_lft forever preferred_lft forever



  • @george1421 said in Interface not ready, waiting for it to come up:

    On your fog server, what is the output of this command ip addr show

    Then in the web ui,

    Fog Configuration -> Fog Settings -> Multicast settings -> UPDCAST INTERFACE

    “ens160” … Master Storage has “eth0” interface
    …the Fog Node has “ens160” interface

    and

    Storage -> Default storage node -> Interface ?

    Multicast has to be the same as Master or as Node ?


  • Senior Developer

    @AlexPDX You can ignore or disable the replication service on the storage node. It’s not really doing much.


  • Moderator

    On your fog server, what is the output of this command ip addr show

    Then in the web ui,

    Fog Configuration -> Fog Settings -> Multicast settings -> UPDCAST INTERFACE

    and

    Storage -> Default storage node -> Interface ?


Log in to reply
 

394
Online

7.4k
Users

14.5k
Topics

136.8k
Posts