Booting from SAN Device 0x80 hang



  • I have seen several posts about FOG and the error Booting from SAN Device 0x80 hangs and will not boot. They are legacy boot and Windows Server 2012.

    I have a Windows 10 image that works fine for Dell Precision 3600, trying to image Dell Precision 3620 with same Windows 10 image. If I boot the computer with no network connection will login with Windows 7 image but not to the network if connected. Gives Booting from SAN Device 0x80 hangs if connected. So I have the same image and it works on the 3600 and not on 3620.

    So what do I need to change so the 3620 can boot and be updated with new Windows 10 image and not make changes to impact the 3600 imaging. Same Image.

    Thanks.


  • Senior Developer

    @lkisser Would you post more information?


  • Senior Developer

    @lkisser in regards here it almost sounds like there could be 2 hard drives on the 3620? If so chances are the drive that is set to boot still has windows 7 installed, and the other drive actually has the windows 10 image on it. This is possible but again we’re left with too few details.


  • Senior Developer

    This is heavily dependent on what you’re doing. Seeing as 3600 != 3620, does the 3620 have a windows 10 capability?

    What type of image are you using? For example, if the image you’re using is OEM, you can only deploy this image to the same make/model of machine. Legally speaking. In order to use a common image you would need to purchase one VL key for each make/model type you have. You would also need to use a different OS, Not the one the manufacturer deployed on the machine you’re using.

    As @Sebastian-Roth has stated, fog is an imaging software. If you deploy an image to a machine, it will not magically switch back and forth to Windows 7 or Windows 10. It will be whatever you deployed to it. Plain and simple. Whether this image works or not.

    Generalizing an image to be hardware independent is a task in and of itself and there are many posts around here and the internet to do such things.

    What does the SAN 0x80 have to do with this? This is an error for some BIOS models. That’s why there’s many different exit types. All this element of FOG does is tell the machine to boot to the first hard drive.


  • Senior Developer

    @lkisser Sorry but I still don’t get why you keep mentioning Windows 7 and Windows 10. Just doesn’t make sense to me.

    FOG is an imaging software. You take an image of one computer (whatever OS is installed) and you deploy it to another one. I can’t see how you could have a generalized Win 10 image, deploy that, fails and you reboot to be back in Win 7?!?

    Sorry if this sounds silly. I don’t mean to be rude. I just don’t understand what you mean. Please try to use more words to explain what you are trying to do.



  • I changed the Exit to HD Type to Grub. This got me to the Windows 7 operating system. Updated the drivers and the firmware, just in case, PC had been sitting for awhile. Tried to deploy the Generalized Windows 10 Image and it will not install. Runs through the process 100%, reboots but goes back to Windows 7. What am I missing?

    Also, FYI, I am new to FOG. Please give me details so I know what I am suppose to do.

    Thanks for the help.

    Liz


  • Senior Developer

    @lkisser From what I understand this has nothing to do with the image you use on the machine but with the machine model (Dell Precision 3620 in this case) itself.

    Have you tried different exit types? (setting in FOG web UI -> hosts’ settings or global setting)


Log in to reply
 

400
Online

7.4k
Users

14.5k
Topics

136.6k
Posts