ERROR: Not able to find a network interface that is up on your system



  • Hello,

    I tried to install FOG server on Ubuntu 18.04 VirtualBox. I get this ERROR: Not able to find a network interface that is up on your system. When I installed FOG on Ubuntu desktop I did not get this error. I am not sure if it is because I answered no to the question “should the installer try to disable the local firewall for you now?”


  • Moderator

    @Dv27842 said in ERROR: Not able to find a network interface that is up on your system:

    I was able to get ufw enabled

    Actually you want the firewall disabled.

    OK so lets back up a bit (mainly since I’ve been bouncing around different threads).

    1. Can you ping 8.8.8.8 ?
    2. Can you ping www.google.com ?

    If you can ping by ip address and not by name then something is messed up with the dns entries. Understand if we are stuck here this is a linux issue and not anything (yet) to do with FOG. For linux there is a file in /etc called resolv.conf. That holds the name(s) of the dns servers for your network. The network configurator should populate this file. If its effectively blank you can add a line like

    nameserver 192.168.1.1
    

    where 192.168.1.1 is the IP address for your dns server for your network. That DNS server needs to be able to resolve internet addresses like www.google.com. If you put the proper nameserver entry in that file you should be then able to ping by host name.



  • @george1421 I was not able to ping nor was able to install a network manager. I input all the network information into nano (netplan). Do you still think I should troubleshoot to get the network manager application in this case. I have set-up a static IP, with other network information including DNS, Gateway. I was able to get ufw enabled (status: Active).


  • Moderator

    @Dv27842 ubuntu firewall: https://linuxconfig.org/how-to-enable-disable-firewall-on-ubuntu-18-04-bionic-beaver-linux

    Name resolution: well this is a bit complicated. I would first see from the FOG server if you can ping 8.8.8.8 if that works then you have a name resolution issue. (first I don’t know ubuntu) There should be a network manager application using the ubuntu gui. In the network manager application there should be a ipv4 tab, and on that tab is where you define the static IP address of the ubuntu server. But also in that area is where you define your local name servers (DNS servers). This information would normally be provided by dhcp, but in the fog server’s case you need to set up a static IP so you will also need to configure a gateway address as well as the dns servers.



  • @george1421 I am not sure if that is the best option. I want to try 1.5.7 first. I did not stop the ubuntu firewall? Do I need to install ufw for it to work? Also I tried the the dev branch but I got this errorScreenshot from 2020-01-09 13-59-40.png


  • Moderator

    @Dv27842 let see if this issue has been fixed in the dev branch.

    do the following from the screen you are on

    cd ..
    git checkout dev-branch
    git pull
    cd bin
    ./installfog.sh
    

    That will switch you over to a prerelease version of 1.5.8 (which supports centos 8, debian 10.2). Ubuntu 18.04 should be supported by FOG 1.5.7.

    But what is strange is your ip addr show gives you only one network adapter and its there. It appears the program is blowing up on sed.

    But again there is a warning message about the firewall. Did you stop the ubuntu firewall (ufw)??



  • @george1421 yes this is a valid IP on a sandbox machine, I can ping it just fine. I am using the FOG 1.5.7 and installed using the git method. Screenshot from 2020-01-09 13-35-53.png


  • Moderator

    @Dv27842 So from a third computer on your network you can ping 192.168.2.203 just fine? 192.168.2.203 is a valid IP address for your business network?

    What version of FOG are you installing? Are you installing it using the git method or tarball?

    Lastly, if you could take a clear screen shot of the error taken with a mobile phone and post the photo here we can see the context of the error too.



  • @george1421 I do have the network adapter set to bridged.




  • Moderator

    While I haven’t used virtualbox a lot, you do need to make sure the virtual box network adapter is bridged to the physical network adapter. You don’t want nat or local only (my words not VB)


  • Developer

    @Dv27842 Please run the command ip a s and post the full output here.



382
Online

6.5k
Users

13.9k
Topics

131.4k
Posts