SOLVED Updating Issues from Dev-Branch

  • Moderator


    Having Issues updating from Dev-Branch

    1. Updating to latest Dev-Branch = Database failed to update

    2. Updating to latest Working-1.6 = NFS Service failure

    Have rolled back VM as we are currently imaging some new machines so unable to get any more info right now. but I can try the update again soon hopefully if more info is needed

  • Moderator

    @falko Bump…

  • I’ve updated things a little more again. Made the pxe menu items sort by the id’s as was originally intended. As a part of that sorting issue, I also made the cached version update so you should be able to see the latest changes without having to do a hard refresh.

    I didn’t see any issues with my PXE Menu, other than the sorting was strange to me (Deploy image was before boot hard drive) but everything worked without an issue.

    Hopefully it will work for you again?

    Thank you,

  • @falko you should be able to do a hard fresh to the browser. I did not force it to update for you. In chrome, hold ctrl + shift + r

  • Moderator

    @Tom-Elliott Thanks Tom for checking this, I just updated ( however and still spammed by the success boxes

  • @falko The weird spamming of notifications should be fixed in the latest. Not quite sure about the issue you’re seeing accessing the boot.php script at the moment. I’m unable to replicate the issue.

  • Moderator


    I have updated to Working-1.6 (

    During Install on setting up and starting nfs server it reports [failed to get unit file state for nfs-server.service no such file or directory] but it does start OK.

    As for imaging I am unable to image from the pxe menu this error

    But I can deploy tasks from the web gui & when I do it returns maybe 20 or so success boxes. This issue also happens when on a Host Management page and I click Update (if I changed the image etc.)

    Another issue is at the end of when the image is deployed I receive this error

    I also seem unable to export the database from the Save Configuration page

    Server is: Debian 8.11 Jessie
    Version: Working-1.6 (
    Kernel: 4.19.64

  • Moderator



    Server is: Debian 8.11 Jessie

    and yes I have jumped to 1.6 and back to Dev-Branch before (everything seemed to work OK, this was a few weeks ago maybe so no Database Upgrade).

    This time however I used VM snapshot to roll back (instead of a downgrade), I’m back in work on Friday so I may be able to get more info then

  • Moderator

    @falko said in Updating Issues from Dev-Branch

    Updating to latest Dev-Branch = Database failed to update

    I would be very interested to know more about this. I have made a big database related change in the last days and so we might need to adjust things. Although I did test a lot I can imagine there being unexpected circumstances causing an error.

    Did you get the error message when opening the web UI to update the schema?

    … working-1.6 …

    We are keen to get more detailed infos about that too! Probably try again und then take a look at the install error log. As well let us know what Linux OS you use.

    I hope you are aware that switching between those two branches can break things!!! Please let us know if you have switched to working-1.6 und back on this install before?