FOG HTTP Server Not Updating after IP Change



  • Hi,

    I recently had to set up UEFI booting on our FOG server as well as moving subnets. I followed the directions from the wiki and I’m able to reach the FOG Admin web interface and see the storage node as well. I changed the IP address in Fog Settings > TFTP Server and also changed it in the Web Server section Fog Settings > Web Server.

    Once I try to boot via UEFI IPv4. It loads the iPXE drivers and shows the correct TFTP:// address but it is not showing the correct HTTP:// address for the boot.php file. I’m including screenshots below, but I’ve updated all of our DHCP scopes, update the ./fogsettings file that previously showed ${next-server} as the value for HTTP://. I tried changing this to the hardcoded IP that FOG will have moving forward but it still showed the old HTTP:// address. Is there anywhere I’m missing changing the old IP address?

    PXEError.png

    e9ae7fcd-6d3c-4eeb-97f8-6bb75e69f390-image.png

    e0cbca1d-bdf6-42be-995f-86397e63055b-image.png

    1b6c23b5-42a2-43c0-afc0-6fa2c0fee1a2-image.png

    Hopefully I’m just overlooking something and it can be fixed quickly.

    Thanks in advance for your help!



  • @george1421
    Changing the settings in the default.ipxe file worked! Man this community is great! I’m going to update my documentation to make note of this so in the event we move subnets again we can tackle this same day!




  • Moderator

    on the fog server in the /tftpboot directory. There should be a file called default.ipxe make sure the IP address is set correctly in that file.

    I would also, if you reset the IP address on your fog server. Go into /opt/fog/.fogsettings file and update the IP address in that file, then rerun the fog installer to fixup all of the other bits.

    You will have hardcode addresses in the default.ipxe file as well as in the web ui in fog settings, and the last bit is the storage node configuration.



  • Can you link the directions you followed?
    Which version of FOG?
    What are the settings for your storage node(s)?
    What are the settings in FOG Configuration \ Fog Settings \ Web Server? nvm


Log in to reply
 

443
Online

6.5k
Users

13.9k
Topics

131.4k
Posts