SOLVED Adobe Acrobat Reader snapin not working

  • Hi all, and sorry for any duplicate.

    I have been generally lucky installing MSI snapins, but not with EXEs installers. There is currently no MSI for acrobat reader, unless you get a contract with Adobe I believe - I could be wrong.

    I have tried installing the actual exe file with /sAll modifier for total silent install from a startup script via Active Directory GPO with success.

    Trying to install AR via FOG snapin as a batch script, with the same option (/sAll) gets queued like for hours, I guess it stalls for some reason.

    Anyone has had luck with Acrobat Reader ?

    Thanks , all the best, Luis.

  • Moderator

    @astrugatch said in Adobe Acrobat Reader snapin not working:

    If I recall correctly the Acrobat exe installer has an MSI baked inside of it.

    There is two ways to grab the MSI.

    1. 7zip will sometimes open self extracting installers so you can grab the contents.
    2. Launch the .exe program but stop at the eula, possibly one later question. Then go to your temp directory The contents of the installer should be in a guid named directory in your temp. The alternate location might be in ProgramData\adobe path.

  • If I recall correctly the Acrobat exe installer has an MSI baked inside of it. If you run it on a machine and don’t complete the install, then go to your app data local low there should be an acrobat folder in there that has the MSI and a CAB. These are what I use to deploy via group policy.

    If your machines are bound you could also do this as a batch script and use a UNC path for the exe and include the arguments in that.

  • Moderator

    I have successfully gotten the exe to work by doing the following:

    1 - Download the latest version of acrobat reader DC for your language and OS version here (this is important because it is the offline installer):

    2 - Compress the file into a .zip

    3 - Create a snapin pack with the following content:
    a - Choose the .zip you just created to upload
    b - Change the file path from “MyFile.exe” to the name of the exe you downloaded earlier
    c - Put the following in the Snapin Pack Arguments section:
    /sALL /msi /norestart ALLUSERS=1 EULA_ACCEPT=yes

    Here is a screenshot of my settings:

    Then you save the snapin, and deploy away!
    Please let me know if this works for you

  • Moderator

    @lperoma Did you get this working? Would be great if you’d share your experience here in the forum.

  • Moderator

    @lperoma No I have not tried Acrobat Reader myself. Though I might give you some hints on what to try. First see if there are logging options for the EXE installer. Then you might try to run it in the same context the fog-client is running in. Search the forum for PsExec and SYSTEM account to find information on this.