Image file size vs Data copied too large



  • I have a Win7 image I’m trying to deploy. It’s take 1.5 hr to deploy to a single machine on a gigabit connection.

    The only thing different I can see is I can’t figure why the file size on the server, doesn’t match the “Data copied:” part of the restore partition screen. I have attached screenshots from the image folder, and the actual deploying screen.

    Size on server: d1p1.img = 9.1MB d1p2.img 16.9GB
    Data copied on restore screen: 154.65 GiB (~166.05GB)

    This doesn’t make sense to me at all. How can a 16GB file become 166GB of data to be copied? On past images, the data copied is the same as the size on server.

    Any help or better understanding would be extremely appreciated. Thank you!



  • [quote=“Tom Elliott, post: 36441, member: 7271”]What is this?[/quote]
    A drunk user ? haha
    I don’t think there is link with the topic.


  • Senior Developer

    [quote=“andrewop, post: 36440, member: 26018”]Hello
    you are welcome to this forum site

    [FONT=Calibri]You can also use Long Path Tool to sort out this problem.[/FONT]

    __________________[/quote]

    What is this?



  • Hello
    you are welcome to this forum site

    [FONT=Calibri]You can also use Long Path Tool to sort out this problem.[/FONT]

    __________________[FONT=Calibri][/FONT]



  • hmm i got an idea is there any option to change upload compression of image? to test it with 0 compression settings or some other ?



  • I’ve tested it for some way’s

    when i set up a Account in widnows and Clean up drives Fog is doin very well with image creation (upload) and data coppied of drives C: and D: same with time to image other laptops is arround 25-35 minutes. But… we cant set any account and image other laptops with this settings when we send this image to new laptop. Windows need to be at Language choice screen, its when windows is installing. we are cloneing this hard drives with other programs and its working but Fog solution is great and it could be best improvment for us.

    1. ive changed Laptop to test how fog will react for 1TB hard drive wihtout setting an system account . And results are… not so good

    HDD
    3 smaller partitions (arround 300mb each) are cloneing very well with proper time and "data coppied"
    1 partition arround 930 GB with data (40GB windows)
    1 partition arround 50 GB wtih (30 GB recovery)

    Fog when start cloneing big partition shows “arround 269GB data to coppied” wtih 2,5hour to finish

    but when he finishes with this partition and start with recovery it shows proper data coppied and very good time

    Basicly we cant create an account to clean up drives in windows.


  • Senior Developer

    The size difference on the server and what’s actually written is because the data is compressed when it’s upload. So it should be smaller than the actual size of the data.

    The disk size variances is interesting to me, but that could very well be because of recovery and or cleanup of the drives. My guess is the systems have the OEM recovery partition on it which is why you’re seeing such a large image size.

    Are you allowed to do a clean install on these systems? At least one of them?



  • Hey, i Have same problem but in my situation the problem is with Windows 8
    1 laptop disk have like 5 partitions

    3 small partitions all arround 100-300mb each of em
    1 Big arround 400GB - system windows 8 (there is like 27GB of data)
    1 smaller arroud 80GB - recovery (there is like 15GB of data)

    the funnest thing is that we got alot of same laptops to image
    but when i create image data when i clone a first laptop with this disk Fog shows 170GB of data to copied and when i change disk and there is same 100% data and cfg the same laptop shows 200GB of data to copied by fog… and each time i swap hard disks on this laptops each swap it shows other number of data to copy all hard drives are 100% same with same image but done with other program and more important is that it takes like 1,5h to finish

    is there any other solution to this problem to lower time to like 20min or 30?

    ive readed the solution but the problem is that i cant interfere in to disk partition size it have to be the same like it is now.

    and btw image of this laptop got arround 42 Gb after cloneing with Fog on server disk but when cloneing this file to other laptops it shows that image whant to copy arround 200Gb but after finishing image of those laptops imageing there partitions and data same like i wrote upper system works and recovery too but it take 1,5h to finish.



  • I can’t remember, but it was way too long. I discovered the problem. I attempted to resize the partition via windows since the drives are huge and we don’t need the extra space. Windows complained that it could only reduce the partition 150GB because of unmovable files. So that made me google resizing partition unmovable files. The fix was as follows, to allow me to shrink the partition:

    [FONT=Trebuchet MS][COLOR=#000000]For some reason Windows can’t figure out how to move some files around on disk. When attempting to shrink a volume, it will only allow you to shrink it to where the last immovable file is located. These are some things I found necessary to temporarily get rid of those immovable files so that an NTFS volume could be shrunk[/COLOR][/FONT]
    [FONT=Trebuchet MS][COLOR=#000000]1- Disable System Restore (Right click on Computer => Properties => System Protection => System Restore)
    2- Disable Virtual Memory (Right click on Comptuer => Properties => Advanced System Settings => Performance (Settings) => Advanced Tab => Virtual Memory (Change) => No Paging File => Set.
    3- Run Disk Cleanup to get rid of Thumbnails, Temporary Internet Files, and a bunch of other files that it makes no sense why they are immovable.
    4- Restart the computer to have #1 and #2 take effect[/COLOR][/FONT]
    [FONT=Trebuchet MS][COLOR=#000000] [/COLOR][/FONT]
    [FONT=Trebuchet MS][COLOR=#000000]Then I resized the partition to a manageable 80GB, to ensure I was past the original 155GB mark that was showing in the “data copied” field.[/COLOR][/FONT]
    [FONT=Trebuchet MS][COLOR=#000000] [/COLOR][/FONT]
    [FONT=Trebuchet MS][COLOR=#000000]Then re-enabled system restore, and virtual memory.[/COLOR][/FONT]
    [FONT=Trebuchet MS][COLOR=#000000] [/COLOR][/FONT]
    [FONT=Trebuchet MS][COLOR=#000000]This fixed my issue.[/COLOR][/FONT]
    [FONT=Trebuchet MS][COLOR=#000000] [/COLOR][/FONT]
    [FONT=Trebuchet MS][COLOR=#000000]I would recommend this process for anyone experiencing imaging that slows down to a crawl. Mine would start at 3GIB/Min and then gradually get slower and slower. It was taking 3 hours to image only 26GB of data. My actual image file sizes were small, but my assumption is that the partition had files located deep into the partition, which FOG had to account for space. This is only a guess with my limited knowledge of file systems/partitions.[/COLOR][/FONT]
    [FONT=Trebuchet MS][COLOR=#000000] [/COLOR][/FONT]
    [FONT=Trebuchet MS][COLOR=#000000]I am happy again w/ imaging a machines it 8 mins. YAH!! LOVE FOG![/COLOR][/FONT]



  • One more question:
    How long are you waiting, while FOG is “resizing partition” before you interrupt the process? This might take a couple of minutes depending on the disk/partition. At least in your screenshot, there is no error message.


  • Moderator

    Are you doing any kind of disk compression or encryption? Is this an Advanced Format drive? Does this happen when you try to restore the image to other physical machines or just this one? Are the BIOS set to AHCI/SATA/IDE correctly? Have you run a disk check on the target drive before trying to restore to check for problems? Did you run a disk check before you uploaded the image to make sure it was error free? Did you try to defrag the original before uploading?

    I don’t know exactly. I just know some things I would try to figure out what is causing it. If you are advanced, you can look through the source code at the commands in the script that setup the partitions and restore the data to see if you can modify or run them separately to get more info on what’s happening.



  • Does anyone have a guess on why the “file copied” size differs from the actual partitions in the screenshots I posted? To me it makes no sense. On a machine I installed Windows with the OEM clean install disc, the image “file copied” size matches the partition size, etc.

    This machine I was forced to use the factory installed Windows because they don’t offer a clean install disc for this machine in x64.



  • I’ve read that FOG is suppose to account for the 100MB system partition. I’ve not had success in the past with Single Partition, but I just tried again anyway, and it stuck on “Resizing partition”. See attachment.

    [url="/_imported_xf_attachments/0/212_IMG_20121130_081421.jpg?:"]IMG_20121130_081421.jpg[/url]



  • There is no need to use “multi partition”, even if there’s the 100 MB system partition. Try “single partition”, as long as you only have one partition (besides the 100 MB) on the disk.

    Edit: This might not solve your problem, but it’s good to know and maybe worth to try.



  • Extra info. I used multi partition, single disk for Windows 7 images due to the extra 100mb system parttion. Worked well on the last one.



  • Screenies attached. Thx

    [url="/_imported_xf_attachments/0/204_IMG_20121128_092451.jpg?:"]IMG_20121128_092451.jpg[/url][url="/_imported_xf_attachments/0/205_screen.png?:"]screen.png[/url][url="/_imported_xf_attachments/0/208_IMG_20121128_104605.jpg?:"]IMG_20121128_104605.jpg[/url]


Log in to reply
 

394
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.