Dell Optiplex AIO 5270



  • Hello all,

    I’m having quite the strange issue here, and I’m unsure if it is model related, or simply Windows 10. For some background I have setup FOG and am using it to deploy out EFI images of Windows 10 for many systems. We have a couple of sysprep’ed images that have worked with dissimilar hardware before since there are 0 drivers installed on these images. We got 20 of these Dell Optiplex AIO 5270’s in for our clients and were attempting to image them. It became clear that the following changes were needed before we could deploy our images:

    • Disable secure boot
    • Change the SATA mode from RAID to ACHI (since RAID caused the drive not to be found withing FOG)
    • Enable the UEFI networking stack (to allow for PXE boot to be enabled)

    And that was about it. We have been able to deploy the image out, however, every time we do, upon reboot there is no “Windows Boot Manager” option to boot from. The only thing that I could think of that may be different from these models is the presence of a TPM chip. We disabled that and attempted to re-deploy with no luck. The other thing we attempted was to capture the image using a non-resizable method as I’ve read that with Windows 10 it can be a bit hit or miss using the resizable option. This also did not change the outcome. Once again, these images and methods have worked on several other computers (makes and models). Any help or insight into what can be done would be a great help. Thanks in advance.


  • Developer

    @Acuity From what I know about this and read between the lines I think this is caused by the Dell Optiplex AIO 5270’s UEFI firmware not being able to find EFI boot loaders by itself. We had other people report this kind of thing and I thought about adding a feature to FOG that would also save a copy of the EFI boot entry with the image and also deploy it to new machines (forum topic). While it seems to be a vital thing to do on first sight I stepped back from the idea because we don’t have many reports on this being an issue at all (1, 2). While on the other hand we have reports on UEFI firmware creating multiple boot entries (new one on every deploy I guess) or somehow messing with the entries by themselves (1, 2) Because of that I decided to better not mess with the EFI boot loader entries as it could cause trouble on systems we don’t know well enough (like dual boot and such).

    Nevertheless you can try to use efibootmgr tool in post deploy scripts to set the boot entry for you. Search the forums for those two things and if you need assistance just let us know.


Log in to reply
 

474
Online

6.4k
Users

13.8k
Topics

130.2k
Posts