Dell Latitude 5300 2-in-1 Network Fail Issue



  • Hi,

    We are looking to purchase a whole heap of Dell Latitude 5300 2-in-1 devices, so we have got one as a trial unit and we are having trouble with it’s compatibility with FOG.

    We have got it setup to PXE boot via EFI and that works OK using the Dell USB-C to Gigabit Ethernet adapter , but when we go into check the Hardware Compatibility we get some errors coming up about being unable to enable the USB device, and then we do the Hardware check it fails on the network side. Strangely enough, if we disconnect the USB adapter while at the ‘select option’ screen, and then reconnect it and select the Hardware Check option it seems to pass on the network side then. But that trick doesn’t work if you are trying to register the device in FOG, so I assume it’s just a glitch that it’s passing.

    We have managed to get it to image through a Dell Thunderbolt Dock that we got with the trial device, but that isn’t going to be a feasible solution when we buy a whole heap of these laptops. Also the USB adapter supports MAC address passthrough which would be useful when registering them with FOG as we would get a different MAC address for every device then rather than just seeing the USB adapters MAC address.

    I assume it’s just a kernel issue, and I’ve tried updating to both the ‘4.19.64’ and ‘5.1.16’ TomElliott kernels but it hasn’t solved the issue.

    Any ideas how we can get this to work?

    FOG Version: 1.5.4 (I know it’s out of date, unfortunately not easy for us to update FOG in our environment, and I don’t think the version of FOG would cause this issue, more so the kernel version?)

    IMG_9404.JPG

    Thankyou!

    Derek!



  • @george1421 had a look at our Dell 5300 device and it doesn’t have the Thunderbolt port. Although we have resolved the issue another way, I may consider looking at getting the rest of the devices optioned with Thunderbolt ports.

    Thanks!

    Derek



  • @Sebastian-Roth thankyou for the suggestion to use the parameter for external NICs! It appears to have resolved our issue. Using the workaround of replugging in the USB adapter when it prompts you to has now allowed us to get the ‘Pass’ in the compatibility test, as well as successfully imaging the device.

    Thanks again!

    Derek



  • @george1421 thanks also for your advice and suggestions, I will look into that as well!



  • @Sebastian-Roth thanks for your reply and suggestions! We aren’t using a USB hub, just connecting the USB-C Ethernet adapter straight into the one and only USB-C port on the 5300 laptop.

    I guess the docking station (that did seem to work with imaging it) probably acts like a USB hub with multiple external USB devices inbuilt into it (e.g Ethernet, video adaptors etc.) which might explain why it worked?

    When I’m back at work tomorrow I will look into your suggestions and see what I can find out. Unfortunately the time difference between us makes it difficult!


  • Moderator

    @Derek-Newbold said in Dell Latitude 5300 2-in-1 Network Fail Issue:

    We have managed to get it to image through a Dell Thunderbolt Dock that we got with the trial device, but that isn’t going to be a feasible solution when we buy a whole heap of these laptops. Also the USB adapter supports MAC address passthrough which would be useful when registering them with FOG as we would get a different MAC address for every device then rather than just seeing the USB adapters MAC address.

    In our company we use the 7400 2in1s and we can image with fog no problem. They were a bit of a PITA when we first got them because they function a bit different than the legacy systems. [Side bar, finding the right spot to get into the bios and pick the F12 boot menu was a trick also find the power buttons at times is only a suggestion to power off drove us nuts]. But back on point, we image them on the bench using a WD15 docks since the WD19 docks were a bit flaking and would not be detected as a bootable device on the 7400s consistently. We also can image using the ethernet to usb-s dongle like this one: https://www.dell.com/en-us/shop/dell-adapter-usb-c-to-ethernet-pxe-boot/apd/470-abnd/pc-accessories

    In the bios (firmware) configuration for the 7400s you need to go to the thunderbolt configuration page and turn on all of the check boxes at the top as well as set the security to “no security” then pxe booting works correctly. We don’t have to unplug anything during pxe booting or imaging.

    One thing I do have to add as a caveat here, we don’t set the target system to pxe boot through FOG to boot the system. When we image the computer is deliberate where I require the IT Tech to sit in front of the computer and press the F12 button to get into the boot manage and select PXE boot to image. So in that way we don’t need to pxe boot just to boot the computer under normal conditions.

    And to add we are using FOG 1.5.7 with FOS Linux kernel is 4.19.64. For your install you may just need to update to that release to get the hardware support, but that is only a guess.


  • Developer

    @Derek-Newbold Do you use a USB hub on the Dell Latitude 5300 by any chance?


  • Developer

    @Derek-Newbold It’s good to know this same adapter is working on a different device. Those external NICs need to be supported by the UEFI firmware to be able to PXE boot from it. But obviously you are well past that point because the Linux kernel is loaded already!

    Strangely enough, if we disconnect the USB adapter while at the ‘select option’ screen, and then reconnect it and select the Hardware Check option it seems to pass on the network side then. But that trick doesn’t work if you are trying to register the device in FOG, so I assume it’s just a glitch that it’s passing.

    Did you know that we have a parameter for external NICs? https://wiki.fogproject.org/wiki/index.php?title=USB_NIC_(usb_network_adapter)
    When using this you will be prompted to disconnect and reconnect the USB NIC on kernel boot up just before it tries to enumerate the network interfaces. Tom added this because in the early days with USB2 and USB3 NICs it didn’t work without if I remember correctly. So you would manually register the host/MAC through the FOG web UI, set the kernel parameter and then be able to image. I am not sure if that will help you here.

    The error messages we see in the pictures make me think that somehow the USB host controller must be different between the Dell Latitude 5300 2-in-1 and the Lenovo L390 Yoga (working out of the box). There is a chance we can make this work (kernel parameters or even kernel patch) if we actually know what is causing this. But it usually takes a week or so (possibly way longer) to figure out and much of testing is needed on your side. I can’t promise you anything.

    A good start would be to boot a couple different live Linux (Ubuntu, Arch, …) from DVD/USB on the Dell Latitude 5300 2-in-1 and see if the NIC works properly. Please test and let us know what you find.



  • Just an update to this. We tested the ‘Dell USB-C to Gigabit Ethernet adapter’ on a Lenovo L390 Yoga device that we are also trialing, and the Hardware Compatibility check passed for that for the Network.

    Does that mean it’s likely to be an issue with the USB controller drivers on the Dell Latitude 5300?

    Thanks,

    Derek


Log in to reply
 

439
Online

6.3k
Users

13.7k
Topics

129.0k
Posts