Issue with EliteBook 830 G6 not receving DHCP

  • Hi all,

    I met with the issue on new laptop Elitebook 830 G6, which cant found dhcp address after step “Perform Full Host Registration and Inventory”. How it looks:

    Booting from Network to Fog interface, I have address, all works well, logged in, then I choose “Perform Full Host Registration and Inventory” and after laptop restart to next step its this error:
    fog issue.jpg

    I have a fog 1.4.4 I know its old but it works well untill now.

  • @george1421 I found that my previous image which I used on Elitebook g5s is having diffrent ethernet driver, its issue with image. I test it on diffrent computer its installed correct. Please disregard my question.

  • Moderator

    @Mightmar said in Issue with EliteBook 830 G6 not receving DHCP:

    install windows and stops with no Ethernet

    Can you provide a screen shot of this error? On the surface that doesn’t sound like a FOS Linux error message.

  • @george1421 I might be too fast with this, it starts imaging, install windows and stops with no Ethernet and diffrent Hostname instead plgdlp010 its plgdpcXX10. Is that issue with image ? or connected to change of kernel ?

  • @george1421 Thank you very much for this, its solved my issue. Its worked and laptop is succesfully imaging.

  • Moderator

    @Mightmar Oh I forgot about the bug in 1.4.4 where the kernel update doesn’t work as expected. So you will have to go with the manual download process.

    The destination for the files are as you found /var/www/html/fog/service/ipxe directory.

    Rename the existing kernels with.
    mv bzImage bzImage.old
    mv bzImage32 bzImage32.old

    Now copy the downloaded files to that directory. And rename them to match the previous files that were moved out of the way.

    mv Kernel.TomElliott. bzImage
    mv Kernel.TomElliott. bzImage32

    That should do it.

    To fix the bug in 1.4.4 to allow the kernel updates via the web ui key in the following
    chmod -R 777 /var/www/html/fog/service/ipxe

    That will change the permissions to allow the web server to update the files in the ipxe directory.

  • last screenshot: sds.PNG

  • First thing I am really not a linux guy :(
    Ok, I am trying to update it with this instructions

    first issue I had is

    is it because we have it locally and and not connected to Internet, so I downloaded version which @george1421 linked
    I am not sure which one I choose, depends on the linux structure ?
    I wonder is 32 cause I found bzImage32 in /var/www/fog/service/ipxe

    and my last question in this post, whats with an extensions .32, .64 ?
    In the instruction is showed just file bzImage32 or bzImge_3.18 I assume just version name.

    I added file from FTP to /var/www/fog/service/ipxe

    And now I suppose I change name Fog_TFTP_PXE_Kernel ? or Fog_TFTP_PXE_Kernel_32 ?

    sorry for long post.

  • Moderator

    @Mightmar Correct. Only upgrade the FOS Linux kernel. Now if you don’t have the I219 nic we need to find what nic is installed in that computer. If you have a windows computer you an get the hardware ID we can look it up that way. But first upgrade to 4.12.x and see if that addresses your problem.

  • Developer

    @Mightmar said in Issue with EliteBook 830 G6 not receving DHCP:

    Is version 1.4.4 its compatible with kernel 4.12.x ?

    Yes, should be! Give it a try.

  • @george1421 I need to only change kernel? No need to upgrade Fog for it ? Is version 1.4.4 its compatible with kernel 4.12.x ?

  • Moderator

    If your EliteBook uses the intel I219-xx series network adapter you will need to update to kernel 4.12.x. FOG 1.4.4 shipped with FOS Linux kernel 4.11.x version of the linux kernel which does not support the intel I219 network adapter. You can manually download the kernels from here:

  • Developer

    @Mightmar Your FOG version is kind of old. The kernel does not support the network interface caed in your EliteBook 830 G6. One way you can go is updating the kernel to a newer version: Web UI -> FOG Configuration -> Kernel Update

    Don’t jump to the very latest kernel but take smaller steps. Probably best if we figure out your current kernel version and see what is needed for the EliteBook 830 G6. Run file /var/www/html/fog/services/ipxe/bzImage and post output here.

Log in to reply