FOG and UEFI/M.2 SSD



  • I have recently created a new FOG server for our imaging solution, and have been running into some issues. At first, I was using legacy boot for pxebooting, since we still have some systems that do not support uefi, but then I discovered the I cannot boot to my m.2 ssd while using legacy boot. So I changed DHCP option 67 to point to ipxe.efi for this uefi system I’m trying to capture an image on. If I turn legacy boot on temporarily to capture the image, and then change back to uefi boot, my base image computer will no longer boot, just going to a bluescreen that tells me inaccessible boot device.

    My next problem is: when I try to uefi pxeboot with RAID On for capturing my image, I get an error message that says: cannot find disk on system (get hard disk). I thought I could just change my UEFI settings to AHCI, capture the image, and then change back to RAID on. When doing this, I again receive bluescreens saying inaccessible boot device.

    Any suggestions?


  • Moderator

    @madeyem said in FOG and UEFI/M.2 SSD:

    Is it really necessary for you to have the PC run in raid on mode? If not, leave it at AHCI

    If you have only a single disk in the computer OR you have multiple disks but have no plans on setting up a raid configuration there is no performance penalty to leave the disk controller in ahci mode.



  • @matt-lowrey said in FOG and UEFI/M.2 SSD:

    I’m going to attempt to create a new fresh image using AHCI instead of RAID. If this works, I have no problem using AHCI instead of RAID.

    Ok, but you can switch your existing RAID On Windows installation to AHCI, following the steps from the link. I did it with my new Dell Optiplex 5070 SFF, which came with an RAID On installation of Windows 10. I also had to disable Secure Boot and enable UEFI Network stack in BIOS to make it bootable with FOG.



  • I’m going to attempt to create a new fresh image using AHCI instead of RAID. If this works, I have no problem using AHCI instead of RAID.



  • @matt-lowrey said in FOG and UEFI/M.2 SSD:

    No, the system doesn’t boot if I leave it on AHCI. It bluescreens with an “Inaccessible boot device” error.

    Follow these steps to make Windows boot in AHCI mode:

    https://support.thinkcritical.com/kb/articles/switch-windows-10-from-raid-ide-to-ahci

    Is it really necessary for you to have the PC run in raid on mode? If not, leave it at AHCI.


  • Moderator

    @matt-lowrey said in FOG and UEFI/M.2 SSD:

    As far as my DHCP server, it’s a Windows DHCP server. I have found the document showing how to create filters in DHCP for UEFI systems, but I couldn’t figure out how to determine what the UEFI architectures we have are. I wasn’t too worried about this since I can just change the option in DHCP whenever imaging a UEFI system.

    https://wiki.fogproject.org/wiki/index.php/BIOS_and_UEFI_Co-Existence#Using_Windows_Server_2012_.28R1_and_later.29_DHCP_Policy

     Type   Architecture Name
               ----   -----------------
                 0    Intel x86PC
                 1    NEC/PC98
                 2    EFI Itanium
                 3    DEC Alpha
                 4    Arc x86
                 5    Intel Lean Client
    >>           6    EFI IA32
    >>           7    EFI BC (EFI Byte Code)
                 8    EFI Xscale
    >>           9    EFI x86-64
    

    Setup these UEFI archs they are the most common.

    From the wiki documentation I would deviate just a bit. Only set dhcp option 66 in your main configuration and then with the filters only change dhcp option 67 for the different uefi modes. In the main configuration set dhcp option 67 to undionly.kpxe. That way if a filter doesn’t match it will boot the bios boot loader by default and then always use the dhcp option 66 which points to the fog server IP.

    As for the raid on mode, turning it to ahci is only needed for imaging, you can change it back once imaging is done. It kind of stinks to do it that way, but you may need to turn back on secure boot so you will be in the firmware possibly anyway.



  • No, the system doesn’t boot if I leave it on AHCI. It bluescreens with an “Inaccessible boot device” error. I did re-image the machine with my pre-sysprep version of the image I made, and I was able to boot after setting the option to RAID on. I’m going to try to sysprep again and capture the image again to see if it works.

    As far as my DHCP server, it’s a Windows DHCP server. I have found the document showing how to create filters in DHCP for UEFI systems, but I couldn’t figure out how to determine what the UEFI architectures we have are. I wasn’t too worried about this since I can just change the option in DHCP whenever imaging a UEFI system.


  • Moderator

    Does the system boot if you leave the settings on AHCI?

    What kind of DHCP server do you have? It is often possible to make it automatically boot UEFI capable computers to UEFI and the rest to legacy.

    It’s true that FOG can’t capture (or deploy) if the disk mode is set to RAID in the BIOS.

    All that said, I’m unsure why your system would fail to boot after a capture.


Log in to reply
 

355
Online

7.4k
Users

14.5k
Topics

136.5k
Posts