Problem with FOS USB boot

  • I created a FOS USB using a CentOS7 server running FOG 1.5.7 following the instructions provided here. I followed the steps specifically for CentOS7.

    I can boot into the menu and upon selection it starts the process and then it errors out.
    FOS Menu.jpg
    FOS Error.jpg
    I also get these errors when I choose FOG iPXE Jumpstart BIOS or FOG iPXE Jumpstart EFI
    iPXE EFI Error.jpg
    iPXE BIOS Error.jpg

    Some guidance would be appreciated.

    Thank you.

  • Moderator

    @xburnerx00 The short answer is it should just work if you have the dhcp boot options set.

    With that said, let me explain why this usb boot disk exists in the first place.

    We have historically seen the pxe booting process hang (stop/freeze/abend what ever you want to call it) in 4 spots that causes the FOG admin troubles.

    1. Either the computer doesn’t have a pxe boot option or for what ever reason iPXE isn’t being sent to the target computer.
    2. iPXE is delivered to the target computer but iPXE will not startup
    3. iPXE will start up but will not start up the FOS Linux kernel (bzImage). We almost always see this in uefi mode due to buggy uefi firmware on the target computer.
    4. In uefi mode the imaging tech is using a network adapter not supported by the computer manufacturer so pxe booting isn’t an option.

    So what the FOS Linux usb boot drive does is boot into Grub and then calls FOS Linux directly from the usb flash drive. This bypasses pxe booting and iPXE eliminating the above conditions. In this setup the Grub menu is a weak analogy to the more capable dynamic iPXE menus.

    We did include iPXE boot loaders on the flash drive to boot iPXE directly from the usb boot stick instead of by PXE. By doing that we can eliminate issues 1 and 4 from above. But any issues with iPXE in 2 and 3 would still exist.

  • Great point on flexibility @george1421, any idea on how to get the ipxe jumpstarters working? I have been using the USB to capture and deploy but I think I may need them eventually and it would be nice to use all features available if needed.

  • Moderator

    @xburnerx00 said in Problem with FOS USB boot:

    I do not see the reason why to use those now that the USB is working.

    There are caveats to booting FOS Linux directly from USB. You also lose some flexibility by not using the iPXE boot loader. So jump starting into iPXE will give you 100% of the capabilities of FOG without using the onboard boot ROM.

    Either way the goal here is to image systems, how you arrive there is up to you.

  • Senior Developer

    @xburnerx00 said in Problem with FOS USB boot:

    As long as I can register a machine and capture/deploy now, I think that’s all I need. Right?


  • Thanks @Sebastian-Roth, changing those settings worked. The FOS USB works now. I was able to register and capture a test image from a laptop that does not have ethernet ports. I tested 3 different USB Ethernet dongles and they were all recognized. Saves me headaches of working on two different models of laptops numbering into the 200’s without ethernet ports.

    Concerning the iPXE jumpstarters, I have the machines I tested on set to Legacy BIOS. Unless I am missing something, I do not see the reason why to use those now that the USB is working. As long as I can register a machine and capture/deploy now, I think that’s all I need. Right?

  • Moderator

    @Sebastian-Roth Sure no problem, did I miss a ramdisk_size=275000 in the tutorial or did I have it set to ramdisk_size=256000.

  • Senior Developer

    @xburnerx00 About the kernal panic: The current init files we provide are bigger than the ones we had when George wrote this great tutorial. So you need the grub.cfg file and change ramdisk_size=127000 to ramdisk_size=275000 in the various kernel parameter lines. I am fairly sure this will fix the boot issue.

    @george1421 I just updated your tutorial. Hope you don’t mind.

    It’s strange both the iPXE jumpstarters won’t work. Is this machine set to UEFI or legacy BIOS (CSM)?

Log in to reply