HP Elitebook 830 Gen 6: Issues Capturing Images and Deploying Images

  • HP Elitebook 830 Gen 6: Issues Capturing Images and Deploying Images

    Currently we us FOG to capture and deploy images of our Windows machines. With each new laptop revision we install a fresh windows 10 installation with latest approved updates and our core applications installed. We then capture an image and then use this image to build all our new laptops going forward (every month we update this image with the latest approved updates to windows and applications and then capture a new image).

    The process has been used for capturing and imaging laptops across different models and generations for example

    HP 430 G2
    HP 820 G3
    HP 250 G6
    HP 830 G5

    The only issue we have come across is with the new HP 830 G6 laptops were we are unable to capture an image and also deploy an image. The one time we were able to capture an image (never again) we were then unable to deploy it to the same generation of laptops or back to the same laptop or even capture an image again. We have also attempted to deploy an image using the image we currently use for the HP 830 G5 and this had the same results.

    The issue appears to be FOG Software reading and writing to the SSD. The laptop will pxi boot fine to the fog menu, select Deploy Image (enter creds) and then start the Partclone process and hang for 25 minutes at the starting to restore image screen doing the first partition of 100MB (EFI system). Then it will start the writing of process of the 2nd partition and then slow down even more at the The process will take ages to start and then slow down to a halt stating it is writing at speeds of 450kb/min which would mean it would take 100hr + to deploy the image which we have never complete also the software does not error due to the fact it is running but at a very slow rate. We have never left the process running longer than a full day.

    Steps Attempted:

    1. Updated the kernel on the Fog Server to the latest. No effect.
    2. Swapped SSDs from and to a G5 to a G6. No effect – SDD imaged fine within the G5.
    3. Attempted to deploy using a HP docking station. No effect.
    4. Updated the bios to the latest version of R70 Ver 01.02.01. No effect.
    5. As part of our process we disabled Secure boot. We have attempted via legacy boot as well. No effect.
    6. Performed Bios factory reset along with the security reset within the BIOS. No effect.
    7. Also disabled TPM.
    8. We have also change the capture settings using no compression and no resizing of partitions.

    There seems to be an issue with the new chip 9th Gen. I was wondering if there a function to turn on verbose logging to see what is actually happening.

  • Moderator

    @rocksteve69 Unfortunately I’m unsure what else to try at the moment.

  • @Quazz

    Sorted, the Kernel panic issue, we just snapped the server back to before we upgraded last Friday. All working in that respect. Still got the original issue :(

  • Moderator

    @rocksteve69 You may have to increase the ramdisk size in the settings on the WebUI

    It’s at TFTP settings (set it to something like 275000)

  • Now we appear to have another issue that is effecting every device we attempt to image or capture.

    After ipxe into the Fog client, selecting Deploy and then selecting an image we get the following error:

    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

    We have attempted rolling back the Fog Version to 1.5.7 and the Kernel 4.19.64 and no joy.

    Any help would be awesome.

  • @Quazz

    We have attempted the updated bzImage529 and no effect. Same issues. We also started having issues before Partclone starts where intermittently after the ipxe boot it loads the Fog screen, select deploy image, enter creds, select an image and then it hangs at the bzImage529 stuck at 0% and then returns to the Fog screen after 2 minutes.

  • @Quazz said in HP Elitebook 830 Gen 6: Issues Capturing Images and Deploying Images:

    Copy to /var/www/fog/service/ipxe
    Change kernel in WebUI to bzImage529

    Excellent, will test and will report back

    Cheers again for the help.

  • Moderator

    @rocksteve69 https://drive.google.com/open?id=1WLjXQYKDoZCAxF5Gfjeva2O-MLrfQ40N

    Copy to /var/www/fog/service/ipxe

    Change kernel in WebUI to bzImage529

  • Moderator

    @rocksteve69 Thanks!

    Looks like that version is running on Linux Kernel 5.2.9-2, potentially including some NVME fixes for certain devices.

    I am compiling that kernel, hopefully that’s the only thing needed, because otherwise I am unsure where to start looking.

    Will post a link here when it’s done.

  • @Quazz

    Version I used was:


    Attempting a Samsung version too.

  • Moderator

    @rocksteve69 Which Clonezilla version was this?

    @Developers Could this be partition alignment related or was that already fixed ages ago? I can’t remember.

  • @rocksteve69

    I have also attempted to use Clonezilla on the Hynix. I took an image successfully onto a usb drive was able to successfully deploy to a know G6 that failed to image using FOG with a Hynix drive with no issues.

  • @Quazz

    Unfortunately no difference :(

  • Moderator

    @rocksteve69 That’s fine, try that one. As long as it’s before kernel 4.11

  • @Quazz said in HP Elitebook 830 Gen 6: Issues Capturing Images and Deploying Images:

    Sorry, can you try Kernel 4.9.11?


    When I go to the Kernel update list there is no 4.9.11 only 4.9.1

  • Moderator

    @rocksteve69 Sorry, can you try Kernel 4.9.11?

  • @Quazz

    We have tried version 4.18.11 and it has had no effect. Still the same issues.

  • @Quazz

    Excellent, I schedule a down grade of the Kernel and report back my findings.


  • Moderator

    @rocksteve69 I’ve looked into this a bit more and there’s some people complaining about NVME speeds declining greatly when they update Linux kernel to a version above 4.9 (4.9 being a version that works fine for them)

    So maybe trying an older kernel version can help.

    Of course, the problem you can run into then is that other parts of your system aren’t supported, but it’s worth a try!

  • @george1421

    Downloading Clonezilla to give it a test.

    Interesting though when I try to capture an image of a G6 with a Hynix it goes through the motion up until Partclone starts takes no data and states capture completed successfully and reboots within a few seconds. No errors reported and reports back that the task is completed to FOG which clears the task.

Log in to reply