Optiplex 990 Issues



  • Is anyone here trying to use FOG on the Optiplex 990 series? I just got these in and are looking to implement them into our student labs. The issues that I am having:

    1. Cannot Image using DVI video on the desktop. Must use VGA, which then prompts after the POST screen that an unsupported video configuration was detected every time the machine is restarted. Is there any way to get FOG to work with DVI?

    2. Optiplex 990 came with BIOS A06 installed, which when used, FOG says that it is not compatible. I have updated to A07, and the same error occurs. I have not tried A10 yet. Has anyone had any success with a BIOS version for the 990s?

    3. Boot Loop. The computer is stuck in a boot loop. I have NIC as the first option, and HD as the second option. The computer will boot into the NIC to check with FOG if there are any tasks, and when there is not, the quick FOG menu appears and auto-selects “Boot from Hard Drive” and the computer restarts. When this happens, it just repeats itself and doesn’t go back into the Native OS until I choose the Hard Drive from the boot options using F12. Any suggestions on how to bypass this? I don’t want to have to select F12 for anything, including when I want to push or pull an image from the FOG server.

    TIA!!



  • I had the same exact issue before with Optiplex 790 Series. In order to resolve this issue you need to rebuild your FOG kernel with the latest KITCHENSINK and import your drivers.

    [url]http://fogproject.org/wiki/index.php?title=Building_a_Custom_Kernel[/url]

    Hope it helped.



  • I had the same exact issue before with Optiplex 790 Series. In order to resolve this issue you need to rebuild your FOG kernel with the latest KITCHENSINK and import your drivers.

    [url]http://fogproject.org/wiki/index.php?title=Building_a_Custom_Kernel[/url]

    Hope it helped.



  • [quote=“Al@akuni, post: 622, member: 250”]Yeah I also wrestled with Optiplex 990s and FOG for quite a while.
    I found that the default kernel on FOG 0.32 seemed to work (i.e it would deploy images) on Optiplex 990s. But yes, I got the same ‘fuzzy screen’ problem that you did. I found the following fix in the old forums and it seemed to work for me:

    [COLOR=#555555][FONT=Arial][SIZE=2]Put [B] acpi=off nomodeset[/B] in FOG_KERNEL_ARGS. You can do for all your hosts via the Other Information Menu->Fog Settings->[/SIZE][/FONT][/COLOR]FOG_KERNEL_ARGS[COLOR=#555555][FONT=Arial][SIZE=2], or you can edit per host settings via the Host Kernel Arguments field.[/SIZE][/FONT][/COLOR]

    I ignore the BIOS warnings - they don’t seem to have any effect, if you just wait for about a minute the image should start deploying regardless.

    Boot Loop. Yep this is a pain. I’ve seen the chainloading workaround suggested by others, but I’m reluctant to implement it on my FOG server to fix a problem on one model of desktop. I haven’t therefor set my 990’s to default to NIC as first boot. It’s a pain because unlike old models of Optiplex the 990 doesn’t have the BIOS setting that tells the machine to boot to NIC when it receives a Wake-on-Lan package. So basically I am having to use F12 every time i want to image a 990 - even in a big lab.[/quote]

    You maybe correct the default kernel for ver. 0.32 should work on those 990’s but if that kernel is used on the optiplex 780’s video will react the same



  • Yeah I also wrestled with Optiplex 990s and FOG for quite a while.
    I found that the default kernel on FOG 0.32 seemed to work (i.e it would deploy images) on Optiplex 990s. But yes, I got the same ‘fuzzy screen’ problem that you did. I found the following fix in the old forums and it seemed to work for me:

    [COLOR=#555555][FONT=Arial][SIZE=2]Put [B] acpi=off nomodeset[/B] in FOG_KERNEL_ARGS. You can do for all your hosts via the Other Information Menu->Fog Settings->[/SIZE][/FONT][/COLOR]FOG_KERNEL_ARGS[COLOR=#555555][FONT=Arial][SIZE=2], or you can edit per host settings via the Host Kernel Arguments field.[/SIZE][/FONT][/COLOR]

    I ignore the BIOS warnings - they don’t seem to have any effect, if you just wait for about a minute the image should start deploying regardless.

    Boot Loop. Yep this is a pain. I’ve seen the chainloading workaround suggested by others, but I’m reluctant to implement it on my FOG server to fix a problem on one model of desktop. I haven’t therefor set my 990’s to default to NIC as first boot. It’s a pain because unlike old models of Optiplex the 990 doesn’t have the BIOS setting that tells the machine to boot to NIC when it receives a Wake-on-Lan package. So basically I am having to use F12 every time i want to image a 990 - even in a big lab.[COLOR=#555555][FONT=Arial][SIZE=2][/SIZE][/FONT][/COLOR]



  • [quote=“Amanda, post: 602, member: 243”]Is anyone here trying to use FOG on the Optiplex 990 series? I just got these in and are looking to implement them into our student labs. The issues that I am having:

    1. Cannot Image using DVI video on the desktop. Must use VGA, which then prompts after the POST screen that an unsupported video configuration was detected every time the machine is restarted. Is there any way to get FOG to work with DVI?

    2. Optiplex 990 came with BIOS A06 installed, which when used, FOG says that it is not compatible. I have updated to A07, and the same error occurs. I have not tried A10 yet. Has anyone had any success with a BIOS version for the 990s?

    3. Boot Loop. The computer is stuck in a boot loop. I have NIC as the first option, and HD as the second option. The computer will boot into the NIC to check with FOG if there are any tasks, and when there is not, the quick FOG menu appears and auto-selects “Boot from Hard Drive” and the computer restarts. When this happens, it just repeats itself and doesn’t go back into the Native OS until I choose the Hard Drive from the boot options using F12. Any suggestions on how to bypass this? I don’t want to have to select F12 for anything, including when I want to push or pull an image from the FOG server.

    TIA!![/quote]

    i have quite a few of these and the way i got around it was to use a different kernel, i dont remember which i choose but try updating to a different kernel



  • The BIOS errors are obnoxious, but for the most part harmless, at least they generally don’t prevent imaging from occurring.

    The fogproject wiki link I posted describes how to setup chainloading in FOG, but it is rather light on details explaining what chainloading is… the [URL=‘http://en.wikipedia.org/wiki/Chain_loading’]wikipedia article on chainloading[/URL] is slightly more descriptive but is not very thorough…

    Chainloading, in this context, could be described as linking from one boot device to the next. In theory, when a computer network boots to FOG it pulls down PXELINUX, which includes the FOG boot menu, unless a task is assigned to that host, and when no task is assigned and no action is taken the boot menu attempts to return to the BIOS for the next boot device. For some reason, and there are some opinionated explanations of this around the internet, certain BIOS/chipsets (generally seen with newer Dell Optiplex models) don’t accept the return to BIOS for the next boot device and promptly reboot. Chainloading bypasses the return to BIOS and statically calls the first disk drive on that system. This method has it’s drawbacks, and is not ideal, but so far I’ve been unable to find an alternative.



  • I have tried a few different kernels, and nothing has worked thus far. When I see the BIOS error, it typically goes through with the imaging, just thought that it was weird that it said there was a BIOS issue.

    Can you explain chainloading to me?

    This is what the monitor looks like when using DVI -
    [IMG]http://i41.tinypic.com/xba5hg.jpg[/IMG]



  • [URL=‘http://www.fogproject.org/wiki/index.php?title=FIX:_Chainloading_alternate_SYSLINUX_to_force_boot_from_first_hard_drive’]Chainloading[/URL] can fix the boot looping issue. I’ve never encountered the DVI issue, and while FOG likes to complain about BIOS not being supported it generally works anyway. If it refuses to work with the BIOS you might want to try using a different kernel, in the FOG console under About->Kernel Updates.


Log in to reply
 

384
Online

39.4k
Users

11.1k
Topics

105.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.