Getting Dells to PXE boot with UEFI



  • I am attempting to get my Dell Optiplex models to PXE boot to the FOG server with UEFI. If we run legacy BIOS we can get them to PXE boot just as we would like them to, but if we enable PXE with UEFI it fails and then just boots to the hard drive anyway.

    I can F12 it and boot it using the legacy BIOS PXE boot, but I would like to get UEFI working as we want to move to that for all our Optiplex models to boot from. I am using 64 bit Kernel 4.19.64 but I suspect I am missing something to get this to work. I really want this because I hear Dell is dropping legacy BIOS entirely very soon in coming models. Any assistance is appreciated. I am a FOG newbie just for context.


  • Moderator

    @rogalskij ipxe.efi is the default file for UEFI.

    However, it may pay to take a look at the default FOG DHCP config so you can serve both legacy and UEFI clients alike.

    https://wiki.fogproject.org/wiki/index.php?title=BIOS_and_UEFI_Co-Existence#Using_Linux_DHCP



  • @Quazz and @george1421 Thank you both. I appreciate the assistance. I tried ipxe.efi and it worked! I now have my Dell Optiplex models PXE booting using UEFI just the way I was hoping. Only oddities is the screens are a bit smaller, and the PXE boot shortcut is now “esc” instead of my custom shortcut. That is a small first world problem however. Thank you all again this community is fantastic!


  • Moderator

    @rogalskij Ah ok you are using a linux dhcp server? If that is the case it appears you are not using the one supplied by The FOG Project. No worries, I can give you an example of how to dynamically manage sending the right boot file based on the type of target computer that is booting. This configuration supports both bios and uefi systems without you needing to interface .

    Dang Quazz you are too fast.


  • Moderator

    @rogalskij ipxe.efi is the default file for UEFI.

    However, it may pay to take a look at the default FOG DHCP config so you can serve both legacy and UEFI clients alike.

    https://wiki.fogproject.org/wiki/index.php?title=BIOS_and_UEFI_Co-Existence#Using_Linux_DHCP



  • I have this configured for my DHCP PXE section. I have omitted the ip addresses in favor of “x” in their place for network security reasons. The DHCP server is a linux server.

    subnet x.x.x.x netmask 255.255.240.0 {
    authoritative;
    option routers x.x.x.x;
    option subnet-mask 255.255.240.0;
    next-server x.x.x.x;
    filename “undionly.kpxe”;

    I am currently using “undionly.kpxe” for option 67 as shown above. This works for legacy bios PXE but not UEFI. There are a bunch of files in /tftpboot and am unsure which “efi” file to use for uefi pxe booting.
    0


  • Moderator

    What do you have configured for dhcp option 67?

    Also do you have a linux or windows 2012 or newer dhcp server?


Log in to reply
 

285
Online

7.4k
Users

14.5k
Topics

136.7k
Posts