TFTP Open Timeout

  • Good afternoon good people,

    I’ve set up a few fog servers in the past few months on a couple of Raspberry Pi 3 B+ and have had few to no issues for the most part. The company I work for however is in the process of a network equipment infrastructure upgrade. We are moving to Fortinet switches and firewalls. I am working on testing the fog server on this new equipment but I am running into an issue:

    The Raspberry Pi is pulling IP from our DHCP server at During setup I’m using:
    Network Adapter: Eth0
    DHCP Server:
    Use FOG as DHCP: No

    I’ve had our infra team set option 66 to and option 67 to undionly.kpxe.

    The setup works well, no issues getting into the management console. I added the client I am testing with. Now, when I go to capture an image, the Computer PXE boots, searches for DHCP, shows that it found the DHCP server then searches for TFTP and fails.

    It searches for a few seconds for TFTP requests then says PXE-E32: TFTP open timeout

    I’ve tried restarting the tftpd-hpa service, status says its ok. Tried reinstalling FOG multiple times, tried wiping my RPi and reinstalling the OS fresh and reinstalling FOG fresh. I’m not too terribly experienced with this so could somebody help me to determine where I’m going wrong? Could it be a firewall issue maybe?

    Thank you in advance!

  • Next Server IP address was wrong on DHCP server. TFTP is working now! Thank you @george1421

  • Moderator

    @Brendan-Clemente Look at the FOG chat bubble, I have some questions that will be quicker in chat

  • @george1421 Also, this was run on the client with IP I believe it is event number 2 on the file in wireshark

  • @george1421 Sorry for the delay, you can find the output.pcap file at the following link:

    Let me know if this is not correct and I can try again.

  • @george1421 The DHCP server is actually set up on the switch itself. Sorry for the confusion. Let me get that capture for you now. And yeah I had an issue previously where I tried to switch the IP and found that in some places the new IP took and in others it was still trying to use the old IP. Since I’ve set up the RPi with a fresh install of Raspbian the IP of the fog server has not changed from

  • FOG TFTP Issue.JPG

  • Moderator

    @Brendan-Clemente You will find that firewall’s don’t make great dhcp servers.

    If the fog server is on the same subnet as the pxe booting client and the dhcp server lets use this tutorial to capture a pcap of the pxe boot:

    Upload the pcap to a file share site and then post the link here. I’ll take a look a what the pxe client is seeing.

    One other note, the IP address of your fog server must never change or you will have a sad fog server.

Log in to reply