SOLVED Failed to Get IP via DHCP

  • Hi,

    Please see attached error message. We just started getting this message with our new Dell Precision 3630 computers. Our Dell Optiplex computers are working fine. This error message occurs after the FOG menu. This was trying to do a quick registration.

    We are running FOG version 1.44. We have also got the same error when connected to a switchport that has portfast enabled.
    Can someone assist? Thanks.

  • Moderator

    @Chuck2000 Ok that’s probably the best solution especially with the newer hardware that is coming out. But some like to hold onto the old versions of fog for some reason. I guess if it isn’t broke don’t fix it.

  • @george1421

    I decided to just go ahead and upgrade our FOG server. The issue is now resolved. Thanks for the quick assistance.

  • Moderator

    @Chuck2000 Ok, I’m going to bet you need to be at version 4.12 to get support for the built in network adapter. You could update via the web gui but there is a bug in some installers where it will error out and not have access to write to the ipxe directory in version 1.4.4.

    You can manually download the kernels from here:

    You could go with the latest kernels, but I’m not sure if they will work with FOG 1.4.4 (they should, but YMMV), I know the 4.12.3 will work with your version of FOG. Its up to you what you want to try. You need the 64 bit and 32 bit versions of the kernels. Save the 64 bit version as bzImage and the 32 bit version as bzImage32

    They go into /var/www/html/fog/service/ipxe on the fog server. Rename the original ones before you swing the new ones into place.

  • Thanks for the quick reply. It is version 4.11.0

  • This post is deleted!
  • Moderator

    @Chuck2000 said in Failed to Get IP via DHCP:

    Dell Precision 3630 computers

    This is probably the root of the issue as well as having and old version of FOG.

    What I need you to do either via the web ui FOG Configuration look at the installed version of the FOS Linux kernel or via the fog server linux console key in file /var/www/html/fog/service/ipxe/bzImage Tell me the version of the kernel.