Cannot deploy "Authy" as a Snapin



  • Hello Guys,

    i need to add the Program “Authy” as a Snapin.

    i created a Batchfile which looks like:

    "\\xxx.local\fileserver\software\Authy\Install.exe" /s
    

    The Batch File is uploaded to Fog as a Snapin with the following Options:

    Snapin Run With: cmd.exe
    Snapin Run With Argument: /c
    Snapin Enabled: Check
    Snapin Timeout: 0 Seconds
    Replicate? Check
    Snapin Command: cmd.exe /c Install.bat

    Even if the Snapin gives me the respond that it was installed successfully the program is not installed on the computer.
    If i start the .bat manually it will install the program without problems.

    Do you guys have some advices for me ?

    Thank you in advance :)



  • @george1421 yes after i tried so much things i remembered that fog runs the batch as SYSTEM. So i think that will be the problem because the Installer copies Files into the Users Folder. I will try your another suggestion with the mapped drive.

    @Sebastian-Roth I tried to get a silent command for the installer and tried the standard lines like /verysilent , /silent , /s, /quiet , /q. And yeah it actually worked only with /s :-D


  • Moderator

    You have to remember that the FOG Client runs as SYSTEM, and SYSTEM has full authority on the LOCAL COMPUTER. SYSTEM does not have access or authority to any external resources. If you want the batch file to work that way you will need to map a drive (using a proper domain account) within the batch file to the remote share and then run the installer from that mapped drive. The alternative method is to deploy the Authy package as an executable if everything is in a compressed executable or use a snapin package (zip file) to include all of your files to be copied to the target computer.


  • Developer

    @DeRo93 Where did you find out about the /s command line switch. I just did a quick search but couldn’t find anything. You might be able to add more command line switches to enable install logging or something like that.

    If i start the .bat manually it will install the program without problems.

    Does it run totally silent without user interaction if you manually run it? Snapins only work if it’s a silent install.


Log in to reply
 

470
Online

5.9k
Users

13.3k
Topics

125.0k
Posts