SOLVED brand new dell latitude 3500


  • @p4cm4n I have the same problem you had. When i look in the dnsmasq log it shows the vendorclass as PXEClient:Arch:00007:UNDI:003016
    so i created dhcp-vendorclass=UEFIBC,PXEClient:Arch:00007:UNDI:003016
    iwith that in the ltsp.conf i get the Boot to FOG UEFI PXE-BC prompt but it never boots the efi
    here is my conf file.
    If anyone could help it would be appreciated.

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    log-queries
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,10.5.0.240
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    dhcp-vendorclass=UEFIBC,PXEClient:Arch:00007:UNDI:003016
    
    
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=tag:UEFI32,i386-efi/ipxe.efi,,10.5.0.240
    dhcp-boot=tag:UEFI,ipxe.efi,,10.5.0.240
    dhcp-boot=tag:UEFI64,ipxe.efi,,10.5.0.240
    dhcp-boot=tag:UEFIBC,ipxe7156.efi,,10.5.0.240
    
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 3
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi #ipxe7156.efi
    
    dhcp-range=10.5.0.240,proxy,255.255.0.0```
  • Moderator

    @Joe-Gill said in brand new dell latitude 3500:

    Ding ding ding ding! I need to set my dhcp server settings for UEFI!!!

    You may want to consider:
    https://wiki.fogproject.org/wiki/index.php/BIOS_and_UEFI_Co-Existence#Using_Windows_Server_2012_.28R1_and_later.29_DHCP_Policy


  • @p4cm4n

    Ding ding ding ding! I need to set my dhcp server settings for UEFI!!! Thanks!!!


  • @Joe-Gill i successfully ran through a pallet of these - 27 - and no issues. this was my process:
    boot into BIOS setup.
    Click enable UEFI network stack, scroll down to AHCI and click it. hit Apply.
    on the left, select secure boot. disable using checkbox - it will ask if you’re sure. hit yes, hit apply. hit exit.

    it reboots, hit f12, network boot ipv4
    it works

    if it doesn’t work for you, make sure your ipv4 UEFI boot settings are setup on your dhcp server (ipxe.efi instead of undionly.kpxe)


  • @george1421

    I just tried it with the Secure Boot off and it failed the same way it did before.

    It never even begins to load the iPXE.

  • Moderator

    @Joe-Gill said in brand new dell latitude 3500:

    I have secure boot enabled.

    Ah that’s it turn off secure boot because iPXE is not signed at all. So the firmware won’t load iPXE.


  • @george1421

    The BIOS says:

    Downloading NBP file...
    
    NBP file downloaded successfully.
    

    Than it returns to starting to load Windows. I never see a FOG PXE boot screen at all. I’m running the 4.19.48 32 and 64 Kernel Versions. I have secure boot enabled.

    I have the following enabled in UEFI:

    Boot Options:
    Onboard NIC (IPV4)

    System Configuration:
    Integrated NIC
    Enable UEFI Network Stack
    Enabled with PXE

    SATA Operation:
    AHCI

    Secure Boot:
    Enable Secure Boot
    Audit Mode (I tried this doesn’t make a difference)

    POST Behavior:
    FAST Boot Thorough

  • Moderator

    @Joe-Gill said in brand new dell latitude 3500:

    I can’t get it to PXE using UEFI

    What doesn’t it do? What errors are you seeing?

    You have to give us a bit more detail more that it doesn’t work (my words).


  • @p4cm4n

    Did you manage to get this figured out? My coworker ordered a pile of these and I can’t get it to PXE using UEFI… Any advice there?

    Thanks!

    Cheers!


  • THANK YOU @Sebastian-Roth

    just got a pallet of 67 of these and would hate to go back to pre-fog days…:)

  • Senior Developer

    @p4cm4n Most probably some kind of Intel software RAID foo. See if you can change from RAID to AHCI somewhere in the UEFI firmware settings.

299
Online

7.6k
Users

14.7k
Topics

138.3k
Posts