Unable to boot into the PXE.



  • Hi, i’m fairly new to fog and pxe in general so I need a little asisstence. I’ve set up both the client and server and I can restart a system, using the web console. How ever I’m unable to boot into the PXE, I have PXE enabled on the system and have it set to the top of the boot priority, but yet I’m unable to boot into the PXE. Any assistance would be great!


  • Moderator

    @0juke If you did not make any changes to your dhcp server then that is the primary problem. PXE booting client relies on 2 settings in dhcp. They are dhcp option 66 {next-server} and dhcp option 67 {boot-file}. These options tell the pxe booting client how to boot.

    For dhcp option 66 that needs to be the IP address of the fog server.
    For dhcp option 67 needs to be undionly.kpxe for bios based computers and ipxe.efi for uefi based computers.

    Without these settings the client computer will not know how to boot.



  • I haven’t changed any settings in the DHCP server as I don’t currenly have acess to it and will not till my manager comes back next week. Are there any other methods we could try to dianose the issue and if all else fails it will be the fault of the DHCP server which can be configured till my higher up returns?


  • Developer

    @0juke As well what text messages do you see on screen when it’s booting. Anything saying that it didn’t get PXE boot information? If answering George’s question doesn’t get you anywhere (it should!), then you might take a video of the client booting, upload that and post a link here.


  • Moderator

    What setting/changes did you make to your dhcp server?
    What device is providing dhcp setting for your network where you want to pxe boot?


Log in to reply
 

372
Online

6.0k
Users

13.3k
Topics

125.1k
Posts