Change the boot order automatically



  • Hello.

    Is there a way to change the boot order automatically after deploying a Windows 10 image in Legacy/BIOS mode?

    When I do a deploy in UEFI mode, the order is changed automatically, the reboots that the system makes during the installation already goes directly through the HD. In Legacy/BIOS I have to change manually after the image deploy, otherwise it will always start with iPXE.

    I’ve tested almost all of the “Exit to Hard Drive Type” options: sanboot, grub, grub_first_hdd, grub_first_found_windows, but all continue to boot from iPXE.

    Thanks.



  • @george1421 said in Change the boot order automatically:

    But we do it this way to make sure we don’t reimage the CFOs computer by accident (again) if everything was automatic.

    That must have been a bad day.


  • Moderator

    @willian said in Change the boot order automatically:

    What I meant is if you configure each machine to enter the boot menu by F12

    On the Dell systems, when its at the Dell splash screen if you hit F12 you will be presented with a ROM boot menu. From there you can (one time) change the boot order from the default hard drive to a network or cdrom boot. There is nothing to configure for this, you just hit 12 for dells and sometimes F1 or F10 for other hardware to get this boot menu. We do this because I want the IT Tech sitting in front of the computer they are to image so they know for sure what system they are imaging. If they have to image 10 machines at one they boot each machine, hit the F12 and select network boot.

    Our approach would be different if I needed to image 30 computers all at once using the FOG multicast imaging, such as in a educational classroom setting.



  • @george1421 Here we also deploy one by one. What I meant is if you configure each machine to enter the boot menu by F12? Or is there a way to configure multiple machines at one time?


  • Moderator

    @willian We only deploy one by one. If you wanted to reimage a classroom of computers then this is NOT the way to go about it. But we do it this way to make sure we don’t reimage the CFOs computer by accident (again) if everything was automatic.



  • @george1421 said in Change the boot order automatically:

    @willian One thing (a bit off point) is that for my company, I enforce my guys to use the F12 boot menu to pick pxe booting. The default boot order is always the hard drive, but they pick F12 boot menu to do a pxe boot. That way on a restart it will go back to the default of a hard drive boot.

    Do you do this for all machines? One by one?


  • Moderator

    @willian For those I don’t know if there is an option for either DOS or Linux command line to change the boot order.

    One thing (a bit off point) is that for my company, I enforce my guys to use the F12 boot menu to pick pxe booting. The default boot order is always the hard drive, but they pick F12 boot menu to do a pxe boot. That way on a restart it will go back to the default of a hard drive boot.

    Your current issue is a limitation of bios mode systems and not really related to FOG.



  • @george1421 I did some testing initially on VMs (Hyper-V), and on two machines, one with Biostar motherboard and another Asus.


  • Moderator

    @willian said in Change the boot order automatically:

    When I do a deploy in UEFI mode, the order is changed automatically, the reboots that the system makes during the installation already goes directly through the HD. In Legacy/BIOS I have to change manually after the image deploy, otherwise it will always start with iPXE

    This is not (specifically) a fog issue. When you install an OS in uefi mode, the installer will typically set the hard drive as the first boot device (overriding what you may want it set to. M$ OS’ will typically do this [change the boot order]).

    What hardware is your target computer. If its Dell there is a chance because the CCTK kit can change the bios setting in a script.


Log in to reply
 

301
Online

6.8k
Users

14.1k
Topics

133.3k
Posts