TFTP won't start at the installation



  • Hello here,

    I have to create a fog server but i have a problem during the installation.

    I followed this tuto (in French) but i had an issue with TFTPD-hpa, i couldn’t install it because cannot open IPv6 socket, disable IPv6: Address family not supported by protocol after some search i edited the tftpd-hpa default file (/etc/default/tftpd-hpa) and give it an option “-4” who force tftpd to use IPV4 and it worked ! My tftpd-hpa server was installed.

    But after the build of the database (during the installation) the install script couldn’t start the TFPT server
    * Setting up and starting TFTP and PXE Servers................Failed!

    And when i look at journalctl -xe i have the same error than the installation, an IPV6 error.
    When i look at the tftpd-hpa default file, my option -4 has disappeared because the script deleted it.

    I tried to modify the script but i’m a newbi and the only thing i found was the option “-t” (not-buildtftt) but when i write ./installfog.sh -t nothing change and the installation fail…

    I would like to know how to disable this “reset” of the tftpd-hpa default file.

    Thanks a lot for your answer !
    (And sorry for my english ^^’)

    Ps : The OS is Debian 9.9 and my version of fog is 1.4.4



  • @Sebastian-Roth I did it and it’s work ! thanks a lot for your reply ans the time you spent for me :)


  • Developer

    @Onirix Seems like I have missed the important bits last time. From the messages you posted I think you have disabled IPv6 in Debian completely. While this is totally fine if you don’t want to have it enabled it’s not standard and therefore we have not run into it with our tests yet.

    Yes adding -4 to the TFTP_OPTIONS should fix this - see here. But as soon as you re-run the installer it will generate a new /etc/default/tftpd-hpa for you and overwrite your change.

    Note that the default file the installer generates looks like this:

    # FOG Modified version
    TFTP_USERNAME="root"
    TFTP_DIRECTORY="/tftpboot"
    TFTP_ADDRESS=":69"
    TFTP_OPTIONS="-s"
    

    So if you want to keep IPv6 disabled I would suggest you run the installer like this: ./installfog.sh -X - this way it should still go ahead even if it fails to start TFTP in the first place. Then when the installer is finished you can modify /etc/default/tftpd-hpa, manually start TFTP and go ahead.



  • @Sebastian-Roth I’m sorry i was in holidays, i just reinstall debian and retry to install fog with the installer and like the first time the package tftpd-hpa installation failed (but this time unzip, vsftpd, wget and xinetd failed too)

    when i open jouralctl -xe i have these lines

    Jun 11 06:52:36 fogif in.tftpd[24233]: cannot open IPv6 socket, disable IPv6: Address family not supported by protocol
    Jun 11 06:52:36 fogif in.tftpd[24233]: Cannot set nonblock flag on socket: Bad file descriptor
    Jun 11 06:52:36 fogif tftpd-hpa[24227]: Starting HPA's tftpd: in.tftpd
    Jun 11 06:52:36 fogif systemd[1]: tftpd-hpa.service: Control process exited, code=exited status=71
    Jun 11 06:52:36 fogif systemd[1]: Failed to start LSB: HPA's tftp server.
    -- Subject: Unit tftpd-hpa.service has failed
    -- Defined-By: systemd
    -- Support: https://www.debian.org/support
    --
    -- Unit tftpd-hpa.service has failed.
    --
    -- The result is failed.
    Jun 11 06:52:36 fogif systemd[1]: tftpd-hpa.service: Unit entered failed state.
    Jun 11 06:52:36 fogif systemd[1]: tftpd-hpa.service: Failed with result 'exit-code'.
    Jun 11 06:52:57 fogif systemd-journald[44]: Forwarding to syslog missed 124 messages.
    -- Subject: One or more messages could not be forwarded to syslog
    -- Defined-By: systemd
    -- Support: https://www.debian.org/support
    --
    -- One or more messages could not be forwarded to the syslog service
    -- running side-by-side with journald. This usually indicates that the
    -- syslog implementation has not been able to keep up with the speed of
    -- messages queued.
    

    So, i don’t think it’s a problem about the version of fog or the OS

    The first time i reached to install tftpd-hpa by going in /etc/default/tftpd-hpa and give the -4 argument (to forcing IPV4 yes ?)

    # /etc/default/tftpd-hpa
    
    TFTP_USERNAME="tftp"
    TFTP_DIRECTORY="/srv/tftp"
    TFTP_ADDRESS="0.0.0.0:69"
    TFTP_OPTIONS="--secure -4"
    
    

    Is it a correct solution ? Currently i didn’t did it.

    Thanks a lot !


  • Developer

    @Onirix Any news on this?



  • Thanks a lot for your reply, i will do a clean install of debian and fog then i tell you if it’s resolved or not



  • @Sebastian-Roth said in TFTP won't start at the installation:

    @Onirix I probably need to test with Debian 9.9 myself to figure this out. Not sure when I will get to this.

    I see you’ve already tested it, but the daily install tests - in the case of Debian 9 - always are testing the very latest version of Debian 9 automatically every day. Arch is always the latest version. Centos 7 is always the latest centos7. Fedora 30 is always the latest 30. Ubuntu 18.04 is always the latest 18.04.xx.


  • Developer

    @Onirix I have just done a complete fresh clean Debian 9.9 setup and installed FOG without any issue. We might be able to figure out what’s wrong in your case but I’d think you’ll be way faster if you just start over again from scratch. Do a clean install and use FOG 1.5.6 from the beginning. I am fairly sure this won’t cause any trouble for you.


  • Developer

    @Onirix I probably need to test with Debian 9.9 myself to figure this out. Not sure when I will get to this.



  • @Sebastian-Roth said in TFTP won't start at the installation:

    Setting up and starting TFTP and PXE Servers…Failed!

    I mean “Setting up and starting TFTP and PXE Servers…Failed!” and the option -4 who is deleted by the script


  • Developer

    @Onirix What do you mean by same error? The “Setting up and starting TFTP and PXE Servers…Failed!” when installing or the error when booting a client machine?



  • Thanks for your quick reply, i’m sorry i didn’t saw your post before…
    I tried to install the lastest version but i have the same problem, it’s possible to be a DHCP problem ?


  • Developer

    @Onirix May I ask you to use the most current version 1.5.6 as of now. There was a bug in an earlier version that prevented an install on latest Debian…



332
Online

6.0k
Users

13.4k
Topics

126.2k
Posts