PHP7.1 failed during confiming package installation on ubuntu



  • Hi Fog gurus,

    Having an issue installing Fog on Linux Mint 19.1. If its best to use another distro please advise…

    Anyway, here is the error I get…

    Thanx for any and all help with this as I’d like to get this running very quickly!!!

    • Installing required packages, if this fails
      | make sure you have an active internet connection.

    • Adding needed repository…OK

    • Preparing Package Manager…OK

    • Packages to be installed:

      apache2 bc build-essential cpp curl g++ gawk gcc genisoimage gzip htmldoc isolinux lftp libapache2-mod-php7.1 libc6 libcurl4 liblzma-dev m4 mysql-client mysql-server net-tools nfs-kernel-server openssh-server php7.1 php7.1-bcmath php7.1-cli php7.1-curl php7.1-fpm php7.1-gd php7.1-json php7.1-mbstring php7.1-mysql php7.1-mysqlnd php-gettext sysv-rc-conf tar tftpd-hpa tftp-hpa unzip vsftpd wget xinetd zlib1g

    • Skipping package: apache2…(Already Installed)

    • Skipping package: bc…(Already Installed)

    • Skipping package: build-essential…(Already Installed)

    • Skipping package: cpp…(Already Installed)

    • Skipping package: curl…(Already Installed)

    • Skipping package: g++…(Already Installed)

    • Skipping package: gawk…(Already Installed)

    • Skipping package: gcc…(Already Installed)

    • Skipping package: genisoimage…(Already Installed)

    • Skipping package: gzip…(Already Installed)

    • Skipping package: htmldoc…(Already Installed)

    • Skipping package: isolinux…(Already Installed)

    • Skipping package: lftp…(Already Installed)

    • Skipping package: libapache2-mod-php7.1…(Does not exist)

    • Skipping package: libc6…(Already Installed)

    • Skipping package: libcurl4…(Already Installed)

    • Skipping package: liblzma-dev…(Already Installed)

    • Skipping package: m4…(Already Installed)

    • Skipping package: mysql-client…(Already Installed)

    • Skipping package: mysql-server…(Already Installed)

    • Skipping package: net-tools…(Already Installed)

    • Skipping package: nfs-kernel-server…(Already Installed)

    • Skipping package: openssh-server…(Already Installed)

    • Installing package: php7.1…OK

    • Skipping package: php7.1-bcmath…(Does not exist)

    • Skipping package: php7.1-cli…(Does not exist)

    • Skipping package: php7.1-curl…(Does not exist)

    • Skipping package: php7.1-fpm…(Does not exist)

    • Skipping package: php7.1-gd…(Does not exist)

    • Skipping package: php7.1-json…(Does not exist)

    • Skipping package: php7.1-mbstring…(Does not exist)

    • Skipping package: php7.1-mysql…(Does not exist)

    • Skipping package: php7.1-mysqlnd…(Does not exist)

    • Skipping package: php-gettext…(Already Installed)

    • Skipping package: sysv-rc-conf…(Does not exist)

    • Skipping package: tar…(Already Installed)

    • Skipping package: tftpd-hpa…(Already Installed)

    • Skipping package: tftp-hpa…(Already Installed)

    • Skipping package: unzip…(Already Installed)

    • Skipping package: vsftpd…(Already Installed)

    • Skipping package: wget…(Already Installed)

    • Skipping package: xinetd…(Already Installed)

    • Skipping package: zlib1g…(Already Installed)

    • Updating packages as needed…OK

    • Confirming package installation

    • Checking package: apache2…OK

    • Checking package: bc…OK

    • Checking package: build-essential…OK

    • Checking package: cpp…OK

    • Checking package: curl…OK

    • Checking package: g++…OK

    • Checking package: gawk…OK

    • Checking package: gcc…OK

    • Checking package: genisoimage…OK

    • Checking package: gzip…OK

    • Checking package: htmldoc…OK

    • Checking package: isolinux…OK

    • Checking package: lftp…OK

    • Checking package: libc6…OK

    • Checking package: libcurl4…OK

    • Checking package: liblzma-dev…OK

    • Checking package: m4…OK

    • Checking package: mysql-client…OK

    • Checking package: mysql-server…OK

    • Checking package: net-tools…OK

    • Checking package: nfs-kernel-server…OK

    • Checking package: openssh-server…OK

    • Checking package: php7.1…Failed!
      root@fog:/home/m/fogproject-1.5.5/bin#

    I also checked to see if it was installed…which seems to be

    php-php-gettext/bionic,bionic,now 1.0.12-0.1 all [installed,automatic]
    php-xml/bionic,bionic,now 1:7.2+60ubuntu1 all [installed,automatic]
    php7.1-mapi/bionic,bionic,now 8.5.5-0ubuntu1 all [installed]
    php7.2-cli/bionic-updates,bionic-security,now 7.2.15-0ubuntu0.18.04.2 amd64 [installed,automatic]
    php7.2-common/bionic-updates,bionic-security,now 7.2.15-0ubuntu0.18.04.2 amd64 [installed,automatic]
    php7.2-json/bionic-updates,bionic-security,now 7.2.15-0ubuntu0.18.04.2 amd64 [installed,automatic]
    php7.2-mbstring/bionic-updates,bionic-security,now 7.2.15-0ubuntu0.18.04.2 amd64 [installed,automatic]
    php7.2-opcache/bionic-updates,bionic-security,now 7.2.15-0ubuntu0.18.04.2 amd64 [installed,automatic]
    php7.2-phpdbg/bionic-updates,bionic-security,now 7.2.15-0ubuntu0.18.04.2 amd64 [installed,automatic]
    php7.2-readline/bionic-updates,bionic-security,now 7.2.15-0ubuntu0.18.04.2 amd64 [installed,automatic]
    php7.2-xml/bionic-updates,bionic-security,now 7.2.15-0ubuntu0.18.04.2 amd64 [installed,automatic]

    Again, thank you for any response!!!

    Air


  • Developer

    @airsine Thanks for posting the issue. We don’t seem to have many Mint users and didn’t notice that obviously they have moved to default to PHP 7.2 being pre installed. At least that is my interpretation of the error without actually having looked into it.

    If you are not bound to use Mint then see George’s and Wayne’s answers.

    If you want to stick to it, try running the installer as php_ver=7.2 ./installfog.sh (note this is just from the top of my head, no promise this is working)



  • I’d recommend Debian 9 minimal installation. Historically with fog, Debian has had the least number of issues.


  • Moderator

    Ideally we’d like to have you use a server OS instead of a desktop OS for fog. Will/should a desktop OS work, yes. But I would stick to Centos 7 (first choice) or Ubuntu 18.04 (second choice) for the server OS for FOG.


Log in to reply
 

319
Online

6.1k
Users

13.4k
Topics

126.4k
Posts