FOS Questions



  • Trying to help a friend out that has some Dell Laptops that wont pxe boot to usb Nic cards that newer versions of the same model boot from without issue. Attempting the FOS USB, got it built and can boot from it. However on selecting FOG Image Deploy/Capture it loads and then gives the following error and will just reboot after a minute. ![alt text](IMG_1115.jpg image url) ANy help would be appreciated.



  • @george1421 No unfortunately I dont have an available to me to test.


  • Moderator

    @ArtLong Have you registered these non-Dell computers with FOG? If so I’d be interested in the outputs from Acer and Toshiba. If you don’t have them currently registered in FOG, no worries. Come to think if it, I have a Surface Pro someplace around here. I’ll need to collect that inventory data too.



  • @george1421 here at my Campus on the PC side its all Dell. In the past 5 years we’ve gone from being a 60/40 Windows/mac shop to a 90/5/5 Chromebook/Windows/Mac shop. Vendor for PC’s is Dell, Vendor for Chromebooks is Acer…Although I did just submit a purchase request for 4 teachers that are going to get the MS Surface Pro 6.

    At our other campuses on the Windows Laptop side they do have Acer and Toshiba laptops in addition to the Dell’s. I’ve just kept my stuff all dell here.


  • Moderator

    @ArtLong What brand of systems do you have on your campus? I have the details for Dell and HP. If you have other manufacturers, I’d be interested in getting some details.



  • @Junkhacker I’m not a programmer to be able to help much here…but a few weeks ago we had a microsoft rep come down to try and help our district IS dept with a roll out of intune. In looking at the various ways to bind the machines for provisioning they had a powershell script that grabbed the serial, windows product id, and the machine hash that you then import into intune so the device can be provisioned…I would think this would be something unique to each machine despite vendor. The powershell script name is Get-WindowsAutoPilotInfo.ps1 …If you look for that file on google yourll find all the articles about it. Here is one of the articles. They dont go into much detail other then they use wmi to gather the info. This file is the content of the ps1 file.


  • Developer

    @george1421 i would think it would be sufficient to have a hash of ${serial} ${asset} ${manufacturer} ${product} ${uuid} would be unique (i’ve never seen a manufacturer leave them all blank, and others like MAC can potentially change)

    one option is, we could use them all, in a way
    we could store them like we store multiple mac addresses, but have fog check the database on new host registration for duplicate identifier data in the database and invalidate those values as “unique” identifiers


  • Moderator

    @Junkhacker Actually we are thinking the same exact thing. What I’m trying to collect is SMBIOS values to find the “device” unique values to string together. It looks like iPXE already support 90% of the fields we need. I think I can add the additional fields to iPXE but I’m not a C programmer. I can mimic coding, but not originate.

    Ideally we want to string together a few value added fields and then create a sha1 hash from that string.

    I have a POC code sample here.

    sserial=`dmidecode -s system-serial-number  | tr -cd '\60-\176'`;
    sserial+=`dmidecode -s baseboard-serial-number  | tr -cd '\60-\176'`;
    sserial+=`dmidecode -s chassis-serial-number  | tr -cd '\60-\176'`;
    
    sprod=`dmidecode -s system-product-name  | tr -cd '\60-\176'`;
    sprod+=`dmidecode -s baseboard-product-name  | tr -cd '\60-\176'`;
    
    sman=`dmidecode -s system-manufacturer  | tr -cd '\60-\176'`;
    sman+=`dmidecode -s baseboard-manufacturer  | tr -cd '\60-\176'`;
    sman+=`dmidecode -s chassis-manufacturer  | tr -cd '\60-\176'`;
    
    sasset=`dmidecode -s baseboard-asset-tag  | tr -cd '\60-\176'`;
    sasset+=`dmidecode -s chassis-asset-tag  | tr -cd '\60-\176'`;
    
    echo -n "${sserial}${sprod}${sman}${sasset}" | sha1sum | awk '{print $1}'; 
    

    So I’m collecting system samples from fog inventory to see if all of these fields are necessary, that is what I’m really after. So far I have Dell and HP examples and both ARE device unique just on the uuid field. The problem is not all hardware manufacturers use the uuid field.


  • Developer

    @george1421 why rely on a single field? why not take a number of them (asset, serial, uuid, etc) pass them to fog via http request. fog can create a hash from the combined values, and that’s the unique identifier. manufacturers can be very inconsistent as to what they put in each field, but what matters is that we have something unique to associate with the hosts. the hash of a set of the info would be unique.


  • Moderator

    @ArtLong I’m trying to collect some data on this issue. Do you have any non-Dell computers registered in FOG? I need to ensure that the non-dell computers (I have Dells on my campus) use the same smbios fields to see if we can come up with a solution to move away from the MAC references as system IDs.


  • Senior Developer

    @ArtLong said in FOS Questions:

    so i think if we can get the host to be locked into the UUID instead of the MAC then he will probably be in pretty good shape

    Yeah good point here. We have had this discussion at length and even started to implement identifying clients via UUID instead of MAC address but only to find out that various machines (hardware and VMs) don’t play nicely and don’t use unique UUIDs. Some are like 000000-....

    The whole topic is kind of on hold as we didn’t come to a great solution for identfying the machines better than by MAC address - which is not perfect at all - we know! The issue is that we need to find a solution that will work right from the beginning of PXE booting where iPXE is used. It’s not enough to do the identifying later on when the Linux kernel is up and we have more options.

    If you are keen to join in and get this topic ahead it would be great!!



  • @george1421 so I had my buddy come down with one of his Dell XPS 13’s…we went through the same process as i did with my machines and produced the same results when selecting option 1. So what we did then was launch a full inventory and create a hostname, because it didnt already exist on my server we didnt get that error. when it was complete i went to my fog server and the host registered…i assigned it a test image to see if it would work and scheduled an immediate image. rebooted machine to the FOG usb and selected option 1 again and this time it imaged. So thats great that part is working…so i think if we can get the host to be locked into the UUID instead of the MAC then he will probably be in pretty good shape.

    -Art


  • Moderator

    @Sebastian-Roth I know there was something that was put into fog where the ethernet adapter was going to be shared among multiple devices but I can’t remember where that was. Was it a secondary interface in the host definition??



  • @george1421 yes its seems like its talking to the FOG server…Im in testing right now with a couple Dell960 sff’s using the EXT USB Nic from Monoprice. But for my friend its a couple Dell XPS 13’s that are known to have problems with pxe and dont come with a built in NIC…after imaging they are going to be on wifi…so i think scheduled tasks are going to be a problem. If I install the FOG client on the laptop it will register the mac of the wifi adaptor. I read somewhere that FOG was changing it to where the clients would register with their UUID, but havent seen that to be the case.

    -Art


  • Moderator

    @ArtLong OK realize that this issue is not related to the task::null from the picture.

    I’m a bit unclear why its asking for a host name (sorry I don’t use 1 nic for multiple computers so I don’t have a baseline understanding).

    I’m assuming that FOS is booting properly right? Its getting an IP address?



  • @george1421 Thanks again for the quick response…what if im testing with an ext USB Nic? When I run the full inventory it doesnt recognize it so it asks for hostname and when i type it in it says it already exists with another MAC address

    -Art


  • Moderator

    @ArtLong OK then the kernel and inits are up to date. Its interesting… Ah darn I see what I missed the first time “Unknown request type :: NULL”

    You didn’t read the caveats in that tutorial. Short answer: Schedule the task in the FOG ui BEFORE you pick option 1 on the fos usb menu.

    You should be golden then.



  • @george1421 Thanks for the quick response… I’m running FOG 1.5.5 on CentOS Server 7. I built the USB following the instructions on this article.

    https://forums.fogproject.org/topic/7727/building-usb-booting-fos-image/4?page=2

    -Art


  • Moderator

    What version of FOG are you running?

    Did you hand create the FOS USB image or did you get it form another source?


Log in to reply
 

395
Online

7.4k
Users

14.5k
Topics

136.6k
Posts