Windows CE Combatability



  • Has anyone else had an issue capturing or deploying a Windows CE image? I have some older terminals that we need to image, however I get a few different errors when trying to capture an image. Since I get different variables on each attempt, I’m wondering if it’s a compatibility issue.



  • I appreciate the help. Luckily just trying the non re-sizable option worked 90% of the time. However, the issue with what appears to be a successful capture and deploy, but complete failure to boot after the deploy is still happening. I’m going to keep playing with that but I think the other issue might be unrelated. I think I’ll repost with more details and let this close out. Thanks for the help.


  • Moderator

    @NivMizzet I would also say to not use resize partitions. The WinCE environment is an embedded OS that doesn’t necessarily have to run on IA32 processors. While WinCE is windows, its a bit closer to linux OS than full Windows running on IA32 architecture.

    With that said FOG only supplies boot kernels for IA32/IA64 and ARM processors. If your WinCE device uses something else, then FOS will not boot. The other thing about WinCE is the OS is at an age where standardized disks were not common. Some uses MMC memory with their own custom disk format (sometimes vfat too).

    The point of that whole post is that FOG might work and might not. Capturing a clear screen shot taken with a mobile phone of the error will help the devs understand where in the imaging process things are going bad.



  • Unfortunately no, I’ve only gotten it twice and I did not take pictures at the time. I’m running it again with the previous suggestion.


  • Developer

    @NivMizzet said in Windows CE Combatability:

    successful capture and image, but failure to boot.

    Please give is more information on the later one. What error do you see? Take a picture and post here.



  • I have not tried it, but I’m willing to give it a go. We can see if that makes a difference, but that doesn’t explain the multitude of issues, including the successful capture and image, but failure to boot.


  • Developer

    @NivMizzet Maybe the CE partitioning is a bit tricky. Would it be possible for you to use non-resizable image type?



  • We have seen resizable partition errors and we have seen errors loading the pxe environment for capturing. And I believe two different Windos CE images we got to capture but upon deployment, at the reboot we got the windows failed to boot error.


  • Moderator

    FOG really doesn’t care about the target OS, but only to restore the boot blocks.

    Do you get errors capturing, deploying, or booting the target OS once it has been cloned?

    Since I have no experience with WinCE devices, I might clone it using single disk non-resizable. What are you trying to do with FOG and WinCE? Are you trying to make a cheap backup system or take a master image and deploy it to many target computers?


  • Developer

    @NivMizzet i can’t say i’ve ever tried using fog with Windows CE, but in theory there’s no reason it shouldn’t work. what kinds of errors are you seeing?


Log in to reply
 

366
Online

5.7k
Users

13.0k
Topics

122.0k
Posts