No udp-sender?



  • Hi, I’m with FOG 1.5.5 over Debian 9.6 and I cannot get multitask working, this is what I get when executing
    systemctl status FOGMulticastManager -l

    ● FOGMulticastManager.service - FOGMulticastManager
    Loaded: loaded (/lib/systemd/system/FOGMulticastManager.service; enabled; vendor preset: enabled)
    Active: active (running) since Wed 2019-01-23 11:10:35 CET; 22min ago
    Main PID: 8775 (FOGMulticastMan)
    Tasks: 2 (limit: 4915)
    CGroup: /system.slice/FOGMulticastManager.service
    ├─8775 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager &
    └─8776 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager &

    Jan 23 11:10:35 phileas systemd[1]: Started FOGMulticastManager.

    As you can see there is no udp-sender at all.
    This is the multicast log

    [01-23-19 11:10:36 am] Interface Ready with IP Address: ********
    [01-23-19 11:10:36 am] Interface Ready with IP Address: 127.0.0.1
    [01-23-19 11:10:36 am] Interface Ready with IP Address: 127.0.1.1
    [01-23-19 11:10:36 am] Interface Ready with IP Address: ********
    [01-23-19 11:10:36 am] Interface Ready with IP Address: ********
    [01-23-19 11:10:36 am] * Starting MulticastManager Service
    [01-23-19 11:10:36 am] * Checking for new items every 10 seconds
    [01-23-19 11:10:36 am] * Starting service loop
    [01-23-19 11:10:36 am] * No new tasks found
    [01-23-19 11:10:46 am] * No new tasks found
    [01-23-19 11:10:56 am] * No new tasks found
    [01-23-19 11:11:06 am] * No new tasks found
    [01-23-19 11:11:16 am] * No new tasks found
    [01-23-19 11:11:26 am] * No new tasks found
    [01-23-19 11:11:36 am] * No new tasks found
    [01-23-19 11:11:46 am] * No new tasks found

    It seems that no multicast task is created.

    PD: udp-sender and udp-receive are working, checked with https://wiki.fogproject.org/wiki/index.php/Multicasting#Troubleshooting



  • @Sebastian-Roth

    Yeah I would rather not re-build my DB from scratch if at all possible. I have fewer hosts now than when I started with FOG but it’s still a large number. I am in the process of setting up another FOG server to do a fresh install and go from there. I do need to clean some things up in there so it may be the time to do this. I did run through the Troubleshoot MySQL Database Maintenance Commands and didn’t get real far with it. I"ll look at that once more before I bite the bullet on starting over.

    I’ll post back to the other thread I started. Hopefully I can figure something out without having to re-do the entire DB…

    Thanks for all of your help! I know you guys put in a ton of time with FOG and it’s very appreciated!!

    Cheers!

    Joe


  • Developer

    @Joe-Gill See what @URfog said:

    I reused my DB backup and it retruned to fail, so the error was in the DB. I have recreated it and now it’s working.

    Possibly you are in the same situation. Not sure if we can figure out what exactly is wrong in the DB. If I’d have heaps more time I’d suggest you send me a dump of your database and I’d try to replicate the issue and find a fix. But unfortunately I can’t afford the time.

    Re-creating the whole DB is probably not an option for you, right?

    Maybe start by cleaning up your DB: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_MySQL#Database_Maintenance_Commands



  • @URfog

    What exactly did you end up doing to fix this? I am experiencing the exact same issue with my installation.

    I"m running Debian 9.9
    FOG 1.5.5

    Thanks!

    Cheers!


  • Developer

    @URfog Oh wow, didn’t expect that! Thanks heaps for letting us know! Great that you figured this out.



  • @Sebastian-Roth said in No udp-sender?:

    @URfog Thanks for the details! I’ll have a closer look later on today or tomorrow.
    @george1421

    Hi all ( @Sebastian-Roth, @george1421), you can leave this problem, I reinstalled the OS and FOG, and with only one machine and one image in my new FOG it worked, I reused my DB backup and it retruned to fail, so the error was in the DB. I have recreated it and now it’s working.

    Thank you so much for your efforts.


  • Developer

    @URfog Thanks for the details! I’ll have a closer look later on today or tomorrow.

    @george1421 said:

    Its been a while since I worked with Multicasting images, but I just scheduled one and it didn’t ask me for a session name when I submitted the task. Looking at the “Task Name” column the session name appears to be “Multi-Cast Task” Is this expected?

    Got me there. I think I never ever used multicast that way. Back at my old working place where we heavily used multicast we’d always schedule it via groups. I’ll check that out as well.



  • Hi @george1421, there they go
    Screenshot from 2019-01-24 14-40-05.png
    IMG_20190124_144749.jpg


  • Moderator

    @URfog said in No udp-sender?:

    Attempting to check in… failed
    Invalid Multicast Session (In line for .)

    Can we get a clear screen shot of this error taken with a mobile phone (unless the entire bit of text on the screen is “Invalid Multicast Session (In line for .)” then it adds no value)? Does it show you the kernel parameters on the error screen?

    The context of the error message sometimes is just as important as the actual error itself.

    Just to be sure when you go to schedule a multicast deployment, you do have hosts listed in the “Hosts in task” list?

    @Sebastian-Roth Its been a while since I worked with Multicasting images, but I just scheduled one and it didn’t ask me for a session name when I submitted the task. Looking at the “Task Name” column the session name appears to be “Multi-Cast Task” Is this expected? (FWIW I’m still running FOG 1.5.4 in production)



  • Hi @Sebastian-Roth, it’s been a “long” time that I’ve been using FOG, it’s not new for me, and it was working.
    The issue that I notice is that of FOGMulticastManager not loading ant udp-sender service.
    I tried creating a Multicast task from

    1. Group
    2. Named
    3. To a single workstation.
      And I can see that task are created but, in the clients I see
      Attempting to check in… failed
      Invalid Multicast Session (In line for .)

    In MYSQL I see

    1. In multicastSessionsAssoc table there is one record per client
    2. In tasks table there is one record per client
    3. In multicastSessions table there is no record

    So, my question is, should it be one record in multicastSessions table?

    If I do ps aux | grep udp Should I find any udp-sender proccess?

    Thanks


  • Developer

    @URfog said in No udp-sender?:

    Where do FOGMulticastManager service gets my external IP from?

    This is done by calling http://ipinfo.io/ip to get the external IP. Tom added that a while ago, I think it’s used to be able to connect FOG servers that run behind gateways. It’s not particularly for the Multicast service but all FOG services use this interface enumeration. We removed/disabled that part in the latest development version weeks ago as it’s a special use case.

    Re-reading most of the topic and especially your initial post I don’t notice much of an issue here. The only statement I see is “I cannot get multitask working”. What exactly does not work? What are your steps to schedule a multicast task? The usual way is create a group, add hosts and schedule a multicast task for this group. I am fairly sure this is working in 1.5.5 as I have tested this not long ago. But there are other ways of multicasting in FOG. Maybe one of the others is not working. Please tell us exactly what you are trying to do.



  • This is ip addr show

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 8c:dc:d4:2e:1e:41 brd ff:ff:ff:ff:ff:ff
        inet 10.11.0.113/16 brd 10.11.255.255 scope global eth0
           valid_lft forever preferred_lft forever
        inet6 fe80::8edc:d4ff:fe2e:1e41/64 scope link 
           valid_lft forever preferred_lft forever
    

    Where do FOGMulticastManager service gets my external IP from?

    Cheers

    [Mod Note] Added code block around output for readability -Geo


  • Moderator

    @URfog Well how are you doing this? Are you using a vlan trunk over the single physical nic?

    If you have a public IP address (i.e. internet based IP address issued by your ISP) please mask that address with 1.1.1.1 for internal IP addresses please leave them as they are because I need to see how you have it setup. Please use this command to display your network configuration. ip addr show and post the output here. Internal or non routable IP addresses are not a security concern if I know.



  • @george1421 said in No udp-sender?:

    @URfog said in No udp-sender?:

    It’s only to hide my IPs, the real IPs are correct

    I guess I asked the question wrong.

    Are they all the same IP address or different? If they are different why, if your FOG server has only 1 NIC adapter?

    Yes, they are different
    First one is local internal IP (intranet), last is external IP. Could it be wrong?



  • Just rebooted.

    Apache2 error.log
    [Wed Jan 23 11:49:50.285987 2019] [mpm_event:notice] [pid 11779:tid 139833165219008] AH00489: Apache/2.4.25 (Debian) OpenSSL/1.0.2q configured – resuming normal operations
    [Wed Jan 23 11:49:50.286042 2019] [core:notice] [pid 11779:tid 139833165219008] AH00094: Command line: ‘/usr/sbin/apache2’
    [Wed Jan 23 14:23:47.088383 2019] [mpm_event:notice] [pid 11779:tid 139833165219008] AH00491: caught SIGTERM, shutting down
    [Wed Jan 23 14:24:27.879540 2019] [mpm_event:notice] [pid 642:tid 139808269137088] AH00489: Apache/2.4.25 (Debian) OpenSSL/1.0.2q configured – resuming normal operations
    [Wed Jan 23 14:24:28.547030 2019] [core:notice] [pid 642:tid 139808269137088] AH00094: Command line: ‘/usr/sbin/apache2’

    php-7.0.log

    [23-Jan-2019 14:23:47] NOTICE: Terminating …
    [23-Jan-2019 14:23:47] NOTICE: exiting, bye-bye!
    [23-Jan-2019 14:24:32] NOTICE: fpm is running, pid 499
    [23-Jan-2019 14:24:32] NOTICE: ready to handle connections
    [23-Jan-2019 14:24:32] NOTICE: systemd monitor interval set to 10000ms

    That’s all


  • Moderator

    @URfog said in No udp-sender?:

    It’s only to hide my IPs, the real IPs are correct

    I guess I asked the question wrong.

    Are they all the same IP address or different? If they are different why, if your FOG server has only 1 NIC adapter?



  • @george1421 It’s only to hide my IPs, the real IPs are correct


  • Moderator

    @URfog What I found suspicious is these messages

    [01-23-19 11:10:36 am] Interface Ready with IP Address: ********
    [01-23-19 11:10:36 am] Interface Ready with IP Address: 127.0.0.1
    [01-23-19 11:10:36 am] Interface Ready with IP Address: 127.0.1.1
    [01-23-19 11:10:36 am] Interface Ready with IP Address: ********
    [01-23-19 11:10:36 am] Interface Ready with IP Address: ********
    

    Why is it saying so many interfaces are ready? Do the stars mask real IP addresses?

    OK, lets say the updsender process is not starting, does either of the apache error log or php-fpm error logs indicate a problem starting udpsend?



  • It’s got only one NIC, eth0, as in /opt/fog/.fogsettings
    As I told before, I think that it is not sending (creating) any udp-sender command, because I cannot see it neither in FOGMulticastManager Service nor in Multicast log

    Thanks for replying


  • Moderator

    Without looking to deep into the logs, I wonder how many network interfaces does this fog server have? If I remember correctly the multicast manager will only bind to the interface defined when the fog installer was first installed. Those settings should be recorded in the hidden file /opt/fog/.fogsettings


Log in to reply
 

405
Online

6.2k
Users

13.6k
Topics

128.2k
Posts