• I created tasks that failed to deploy, and I see no way to cancel these tasks.

  • @Sebastian-Roth Ok, it sounds good that things are looking normal, and I can wait on doing an update. I see your reasoning and agree with that philosophy, on step at a time. I’m also three days away from the semester start so have limited time to troubleshoot and communicate here. I have run a few test images and may have figured something out, I need to complete my testing and will let you know. Thanks again, this has all been so helpful!

  • Moderator

    @MoonDancer Ok, from what I see you server is normally setup, has internet access and an update shouldn’t cause much trouble from what I can gather. That said I am now wondering if you actually need to update just now as there has not changed much in regards to basic image upload/capture. I am not saying you shouldn’t update. I just think this won’t help you in the current situation and we should try to figure that one out first before we proceed.

    I’m still not having success with uploading images.

    Please give us more details on what you do and what happens. Any error messages on the client screen? Please take pictures and post here again.

    By the way, I lately fixed the picture upload in the forums. Should work again. Give it a try.

  • @Sebastian-Roth Thank you, you were right about the browser issue, and that resolved a number of my FOG console problems. Funny, I would normally consider trying another browser, but because it’s on a Linus box I didn’t, and I didn’t know I could open the FOG console on another “Windows” computer, but that makes sense. I will try to find another browser for Linux.

    I’m now able to move forward with my imaging process, and I’m trying another capture to see if I can successfully deploy the new image this time, relating to my other forum post. I will let you know how that goes!

    I ran the commands you recommended will provide an image. I will wait for further instructions before running the installer, I don’t want to make any mistakes. I thought I looked everywhere, I’ve been to that page so many times but totally missed the FOG version.

    I’m still not having success with uploading images.

    Image page:

    Again, thank you so much for your support, I very much appreciate it!

  • Moderator

    @MoonDancer Ok, I am a bit relieved. From what you where saying at first I thought you might have a very old setup. CentOS 7.5 is fairly new and a good Linux OS.

    Don’t run the FOG installer yet. We’ll guide you through that later on.

    Possible your FOG server was setup to run in a separated network without internet connection (numbers on the login page not loading). Some people want to have it this way. It is possible but needs some extra work to be done because you cannot install or update FOG without internet connection. To check internet connection please run the following commands on the CentOS server shell:

    ip a s
    ip r s
    cat /etc/resolv.conf
    ping -c 3
    ping -c 3 ix.de

    Take a picture and post here.

    In the pictures I also see you have FOG version 1.5.4 - it’s printed in the lower right corner, when you are logged in to the web UI as well.

    About the missing buttons for canceling tasks: I can imagine the Konquerer used as browser is not set to run JavaScript or simply unable to render those properly. As the rest seems fine and the buttons are indeed added to that view via JavaScript it’s very likely to be the case. Simply use another browser (even on a different machine within the same network) and open that URL

  • @Wayne-Workman I’m sorry I explained that to Sebastian in another post, I’ve got a number of issues going on. I’m not able to see my version because it doesn’t show up on the login page. Below is a link to that image, as the image upload function is not presently working, you’ll also see other images related to my issues.

    My FOG version was installed within the last 9 months. And I’ve downloaded the FOG installer, but am wondering if there’s any concerns. Do I just run that installer to upgrade FOG, is there any concerns with loosing settings, Hosts, Images, etc.? I’m thinking an upgrade could alleviate my problems.


    If I could be shown how to cancel my tasks, that would drastically improve my situation.

    Thank you for your support, I forgot to mention that on my initial reply!

  • @MoonDancer We still don’t know your fog version.

  • @Sebastian-Roth We’re in the process of updating Linux patches. Is the FOG update just simply running the installer, are there any concerns of loosing your FOG settings, hosts, images, etc.?

  • @Sebastian

    My login page does not display version information, I’m including an image of that page. I’m also including an image of the “lsb_release -a”

    It appears I’m having issues with uploading images so I’ll provide more details.

    My login page does not populate the Fog version information. It’s a newer version, installed within this past year.
    Centos Linus release 7.5.1804

  • Moderator

    @MoonDancer You are welcome. FOG version can be seen on the logon page of the web UI. Either in a blue cloud (very old versions) or just below the user/password entry fields.

    Let’s see what version you have before we go ahead. Upgrading is usually done by getting the latest version and running the installer. Although the larger the gap between your version and current the more issues might arise.

    Is the Linux OS itself updated or is it missing patches as well? Which Linux OS do you have by the way? Run lsb_release -a and post output here.

  • @Sebastian-Roth In another post I’ve seen that you can cancel the tasks from the gui, I’m not familiar with using the console, so I would need step by step instructions.

    And in my previous reply I forgot to thank you for your support, it’s very much appreciated!

  • @Wayne-Workman I had a coworker that installed Fog, I’m just learning, and I don’t know where to find the version information? Should I be considering upgrading, and is that a simple process, without loosing all my data, such as Hosts and Images, etc.?

  • @Sebastian-Roth I’ve gone to Active Tasks but there is no cancel option.

  • Moderator

    @MoonDancer In the list of icons in the top menu of your FOG web UI you have one showing three horizontal bars. There you should find the task and be able to cancel it.

  • @MoonDancer Fog version?