Snapin Update Fail



  • I’m getting the following error when I try to update a snapin:

    0_1543870608888_FTP.png

    I also get the following error when I try to deploy a snapin:

    SnapinClient ERROR: Hash does not match
    

    I figured this was an issue with the TFTP/FTP password, so I followed this guide to verify all of the “fog” user passwords matched (which I now realize wasn’t necessary, so yeah…)

    Wiki --> Credentials / Passwords

    Chain of events: I was on Ubuntu Server 14.04/FOG 1.5.4. I updated Ubuntu, first to 16.04 then to 18.04.1 and then I updated FOG to 1.5.5. I did have to repair the TFTPD-HPA service to get it to start correctly, not sure if this caused the issue with FOG…

    Can anyone enlighten me or tell me what to try next?



  • Thanks for the prompt response Sebastian, you guys rock!

    I was able to resolve this by installing FOG 1.5.5 again after I fixed the TFTPD-HPA issue. You woulda thought I’d tried that already, but you’d be wrong, ugh. Anyway, please mark this as solved and thanks again, Sebastian.


  • Developer

    @chaonatic Can you connect to your FOG server via FTP (command line tool or FileZilla or whatever client you like) using the credentials from /var/www/html/fog/lib/fog/config.class.php?

    As well you want to check that those credentials from the config mentioned above match those you have in /opt/fog/.fogsettings as those would reset the password again when running the installer.


 

439
Online

5.4k
Users

12.6k
Topics

118.9k
Posts