RHEL 7 test



  • For RHEL7 fully updated - with SELinux turned off, using the master branch of FOG…

    The fog installer wanted to install these packages:
    bc curl gcc gcc-c++ genisoimage gzip httpd lftp m4 make mod_ssl mtools mysql mysql-server net-tools nfs-utils php php-bcmath php-cli php-common php-fpm php-gd php-ldap php-mbstring php-mysqlnd php-process syslinux tar tftp-server unzip vsftpd wget xinetd xz-devel

    These packages weren’t found:

     * Skipping package: php-bcmath................................(Does not exist)
     * Skipping package: php-fpm...................................(Does not exist)
     * Skipping package: php-mbstring..............................(Does not exist)
    

    The installer fails and exits here:
    * Stopping web service........................................Failed!

    Fog error log:
    0_1543773229083_fog_error_1.5.5.log

    There was no Apache error log.


  • Developer

    Thanks to Wayne I had access to the RHEL 7 machine for a quick test and seems like we hit it with the latest fix. Installer went through like a charm. So RHEL is back in the race I suppose.


  • Developer

    @Wayne-Workman Just pushed one more change to dev-branch that might get us one step further.


  • Developer

    @Wayne-Workman Maybe found the issue in the log:

    package epel-release is not installed
    No package epel-release available.
    package remi-release-7 is not installed
    warning: /var/tmp/rpm-tmp.9xqo7n: Header V4 DSA/SHA1 Signature, key ID 00f97f56: NOKEY
    error: Failed dependencies:
    	epel-release = 7 is needed by remi-release-7.5-2.el7.remi.noarch
    

    Not sure why it does not want to install epel-release on RHEL 7 yet. Probably needs to be installed a different way.



  • @Sebastian-Roth Not quite yet…

    It wanted to install these:
    bc curl gcc gcc-c++ genisoimage gzip httpd lftp m4 make mod_ssl mtools mysql mysql-server net-tools nfs-utils php php-bcmath php-cli php-common php-fpm php-gd php-ldap php-mbstring php-mysqlnd php-process syslinux tar tftp-server unzip vsftpd wget xinetd xz-devel

    These weren’t available:

     * Skipping package: php-bcmath................................(Does not exist)
     * Skipping package: php-fpm...................................(Does not exist)
     * Skipping package: php-mbstring..............................(Does not exist)
    

    Here’s the log:
    0_1543782561152_fog_error_1.5.5.1.log
    There wasn’t an apache or php-fpm log. I ran this and there was no output: find / -name *fpm*


  • Developer

    @Wayne-Workman Not sure if you read my message in the other thread. Moved things over here to let you know that I have pushed some installer fixes to the dev-branch. They were for Fedora and CentOS but should also fix this particular error you see in RedHat. We’ll if the installer runs through now or if we hit other problems.


  • Developer

    @Wayne-Workman Thanks! As I have been testing those installs on Fedora and CentOS often today I am fairly sure I know why this happens. It’s because the REMI repo does not properly install for RedHat 7 for some reason. Because of that the command yum list --enablerepo=remi,remi56,epel ... will fail and cause it to say “Does not exist”. I am working on removing this at the moment. Testing on CentOS 7 and Fedora 29 right now. I will push a fix to dev-branch later on today. We’ll see if that can fix the RedHat 7 install as well - kind of doubt that it will run all the way through but let’s see.

    Can you possibly add another log file? Quite often those errors will only show up in /var/log/php-fpm/www-error.log… possibly also /var/log/php-fpm/error.log.


 

570
Online

5.4k
Users

12.6k
Topics

118.8k
Posts