Printer Management Level for a group not working



  • I am on the working branch for our school districts FOG servers, and I have noticed that when trying to assign printers to groups, the group is able to assign the printer and default printer settings, however when I try to set the management level it would either only assign “only assigned printers” no matter which one I clicked and saved, or just now when I went to test it won’t change the setting for the group of computers at all and I have to set the management level manually on each station in the group, which is a huge pain for large labs.



  • @Sebastian-Roth awesome, thanks! I’ll give it a while on my VM’s tonight.


  • Developer

    @jflippen said in Printer Management Level for a group not working:

    The group printer page still doesn’t reflect the settings applied, but it I go into the members it does seem to have the correct settings.

    Be aware of the fact that groups in FOG are not persistent. You can read about this in several forum posts. It’s more or less a tool to apply a value to several hosts.

    I just pushed a fix to the dev-branch. Will be in the next release. Marking as solved.



  • @Sebastian-Roth No worries, I know you guys have a lot on your plates. I just wanted to make sure it got noted that there was a bug.

    I can confirm that your workaround works, thanks. The group printer page still doesn’t reflect the settings applied, but it I go into the members it does seem to have the correct settings. I will use this until a patch can be made. Thanks!


  • Developer

    @jflippen Sorry for taking so long but there were always other issues coming in and I just didn’t get the time to look into the printer stuff in the last weeks.

    I can confirm this seems to not work as expected. But I might have found a workaround for you. In the group settings change to “No Printer Management” for example and then click the “Update Default Printer” button further down the page. It’s working for me and I can’t see why it should cause trouble to use this way until we have fixed it.


 

488
Online

5.4k
Users

12.6k
Topics

118.9k
Posts