no viable macs available on quick and full registration

  • Re: Quick Host Registration not working on FOG 1.5.3

    I am seeing this on a fresh install of 1.5.4. I was able to manually add the host from the web gui.

  • @george1421 @Sebastian-Roth
    Thank you gentlemen. That fixed it for me as well. Registration is working again.

  • Developer

    @geekygary @Tywyn @george1421 My fault. When updating the inits I missed out to fix all the places where ip tool is used in our scripts as it has changed with the latest buildroot update.

    I just uploaded fixed inits. So please download init.xz and init_32.xz again to fix the registration issue.

    PS: Possibly I am still missing something and might need to update again. But this particular issue is fixed. I did a quick test and registration is working again with the newly uploaded inits!

    PPS: You can ignore the “db_root: cannot open /etc/target” message for now. I will look into removing this when I have time to.

  • Moderator

    @Tywyn OK just to be clear, you downloaded both the current kernel and inits manually? If so have you tried moving the old kernels back in place? If that failed moving the old inits back in place?

    The concern is one of the two updated files have introduced another issue unrelated to the slow erasure into the environment.

    The dbroot error is a warning message and does not impact the FOS engine.

  • Having the same thing. Running 1.5.4.
    Was able to register hosts until this morning.

    I have done the steps to update the images as Sebastian Roth described here: (last post in this thread).
    I think I successfully registered one more host AFTER having done so, but I am not sure.

    Now I tried to register two other hosts and saw the line “no viable mac available” after having filled out the registration form.

    At the start I see db_root: cannot open /etc/target, but I do not know, whether this has something to do with the fact, that registration does not work anymore

Log in to reply