Create Task Capture Error

  • @george1421 got the file fixed, I can log into the Server just fine through the GUI but I still am getting that error on Uploading and also now downloading an Image to a pc…kinda weird. I made NO changes the last week but it did update maybe a week ago a few files for the Server i ran the git pull and it had a few files to update so I did it…how do I roll back on the Kernel as you were stating?

  • Moderator

    @Sebastian-Roth I remoted into the OPs fog server. I switch him over to the working branch and repulled the using git. After I reran the installer all of the files were where they should be. He was able to schedule a deployment. I think he is good for now.

  • @george1421 I just seen all that and have the file reset to just add the last line in. I had not seen those settings mingled in the text from top to bottom.

  • Moderator

    @butch2861 OK with the config file the way you have it php-fpm will not start. Remove the following from the bottom of the file.

    pm.max_requests = 2000
    pm.max_children = 35
    pm.min_spare_servers = 5                                                                 
    pm.start_servers = 5

    Leave the following line

    php_admin_value[memory_limit] = 256M

    then reboot the server.

    That should allow you to get to the web ui again. Those lines I told you to check are interspersed in the config file.

  • @george1421 I got it George…I puttied into the file and edited it and just copied whole thing into notepad for you; more than 1 way to skin a cat they say…LOL; uploading now.

  • @george1421 I have tried with no luck getting the file onto a usb drive; as I stated I am not a Linux dude…LOL; is it possible to let you onto my pc and SSH into with Putty and check it for me? I am an IT Director for a School District and this Server means alot to me for Imaging; Tom has putty into my machine a couple years ago to help me out and that worked…let me know George; I appreciate you sir.

  • Moderator

    @butch2861 That is not a normal www.conf file. Those settings must have already been in there. The php_admin_value[memory_limit] is defaulted to 32M and commented out by the line starting with a semicolon. Any text that is preceded by a semicolon is ignored.

    Will you upload your www.conf file to the forum here so I can take a look at it. Something is off here.

  • @george1421 I went in to edit the file (only found 1 www.conf btw) and down at the very bottom of the file was the setting for php_admin_value[memory_limit] = 256M and it had “NO” ; in the front of it, also I did not see ANY of this in the file:
    pm.max_requests = 2000
    pm.max_children = 35
    pm.min_spare_servers = 5
    pm.start_servers = 5

    I added this to the end of the file thinking that I needed to put a ; in front of each item and so I did so and rebooted with NO fix. I am still having the issue & btw here is the naming convention for the Image I used WIN1018032 for Image filename and Host is named win10test

  • Moderator

    @butch2861 Let me start with a common thread in regards to FOG 1.5.4 and some issues we’ve discovered since it was released.


    Lets assume is the issue we’ve found after FOG 1.5.4 has been released.

    1. Change to the /etc directory from the fog server linux command prompt.
    2. Search for www.conf file. It can be in a number of locations depending on what version of php is installed. Use this command.
      find /etc -name www.conf (hopefully you will only find one)
    3. Edit that file file and ensure these settings are accurate. Don’t just add them since all should be there except php_admin_value[memory_limit] = 256M you will need to add that entry.
    php_admin_value[memory_limit] = 256M
    pm.max_requests = 2000
    pm.max_children = 35
    pm.min_spare_servers = 5
    pm.start_servers = 5
    1. Save and exit your text editor.
    2. Reboot the fog server.
    3. See if that fixes what is wrong. You really should only see this strangeness under heavy load, but I guess it might show up sooner under certain conditions.

    Also we found there is something strange going on in the linux kernels after 4.15.2, I’m going to recommend that you downgrade your FOG/FOS kernel to 4.15.2. The issue with later kernels is that its taking 3-5 minutes to create the disk structure under certain circumstances, where with 4.15.2 and older its only seconds to create the structure.

    I don’t think any of the above is related to your issue at the moment. I know the above changes have fixed a few things. You don’t have a unique setup using ubuntu 16.04 and FOG 1.5.4. If there was an issue with that combination it would have shown up before with other installations. So that leaves us with a configuration setting that is a bit wonky.

    Since this seems to be related to capturing an image. What do you have configured for the image definition? What about the host definition you want to capture.

    HINT: If you use the free image capture software greenshot you can get a better quality image capture than the entire screen. Its a bit hard to see the small print in your example below.

  • @george1421 I ran this command from the CLI:
    tail /var/log/apache2/error.log
    and also this command
    tail /var/log/php*-fpm.log

    and it produced what I shared abit ago.

  • @george1421
    1.) [Wed Sep 26 12:27:45.649821 2018] [proxy_fcgi:error] [pid 32292] [client] AH01071: Got error ‘PHP message: PHP Fatal error: Uncaught Error: Class ‘ServiceModule’ not found in /var/www/fog/service/servicemodule-active.php:25\nStack trace:\n#0 {main}\n thrown in /var/www/fog/service/servicemodule-active.php on line 25\n’

    2.) butch@GHS-FOG:~$ tail /var/log/php*-fpm.log
    [26-Sep-2018 09:08:25] NOTICE: [pool www] child 25868 started
    [26-Sep-2018 09:08:34] NOTICE: [pool www] child 16604 exited with code 0 after 1307.075349 seconds from start
    [26-Sep-2018 09:08:34] NOTICE: [pool www] child 25933 started
    [26-Sep-2018 09:11:54] NOTICE: [pool www] child 17924 exited with code 0 after 1320.480751 seconds from start
    [26-Sep-2018 09:11:54] NOTICE: [pool www] child 27347 started
    [26-Sep-2018 09:20:29] NOTICE: Terminating …
    [26-Sep-2018 09:20:29] NOTICE: exiting, bye-bye!
    [26-Sep-2018 09:21:41] NOTICE: fpm is running, pid 1013
    [26-Sep-2018 09:21:41] NOTICE: ready to handle connections
    [26-Sep-2018 09:21:41] NOTICE: systemd monitor interval set to 10000ms

  • @george1421 Ubuntu 16.04.5 LTS is the OS; and I have NO Clue on how to capture or view the logs…LOL I am not really a good linux dude…Some general Commands I can do if you all can help there.

  • Developer

    @butch2861 George is perfectly right. We need to see what’s in the logs. See my signature on where to find those logs…

  • Moderator

    @butch2861 Ok we need to generate this error again, then lets look in the fog server linux console. We need to tail the apache error log in /var/log/apache (I think, depends on what OS the fog server is running under) and the php-fpm error log in /var/log/php-fpm to see if there is a clue to what threw this “general” error.

  • @george1421 is the image I posted sufficient?

  • @george1421 ![alt text])0_1537972986671_Fogerror.jpeg

  • Moderator

    Will you provide a clear picture, taken with a mobile phone, of the error so we can see the context of the error message?

Log in to reply