WIN 10 DVD Drive Issues After Imaging



  • So, we have ran into an issue with multiple types of laptops and desktop computers that we have imaged using FOG and sysprep, where the DVD drive disappears or shows up in Device Manager with an exclamation point on it. This occurs no matter whether the machine is the same as the original host. On all devices, the OEM does not have any drivers available for the DVD ROM, as Windows 10 is supposed to recognize the device. You can remove the device from device manager and let Windows find it. When you reboot the device, the issue is right back again. This problem only seems to be on sysprep imaged Windows 10 machines. We have rolled some of these devices back to Windows 7 and the problem disappears.

    We have followed this websites advice (many of these have been found on other websites as well including many from MS…):

    https://www.easeus.com/backup-utility/cd-dvd-missing-or-not-showing-up-in-windows-10.html

    Has anyone else experienced this issue?

    Thanks!


  • Developer

    @Joe-Gill Great to hear you are making progress here! Definitely seems like one of the more difficult ones to figure out. Keep it up! :-)



  • @Sebastian-Roth
    It’s doubtful it is directly linked to FOG. I believe it has to do with SYSPREP…

    To update this:
    We were able to isolate 2 registry entries that were causing the issue. The entries were for the DVD drive itself. Windows 10 was not recreating these entries after it ran sysprep and installed the new devices on the host system.

    I have since ran a fresh install of Windows 10 on a separate machine (similar hardware). The DVD issues were not apparent after the fresh install. We were able to create new registry entries for the DVD drive based on the ones on the “good working” install of Windows 10. I was able to merge those registry keys onto a non-working Host. After that I removed / added the DVD drive. WIN10 recognized the DVD drive. DVD drive stayed installed after reboot. FTW! Hopefully that’s the fix for the rest of the machines we have with the issue.

    Thanks for the moral support. Sometimes that’s all we need!


  • Developer

    @Joe-Gill Is this specific to FOG? have you tried cloning it manually? Same error? Just asking to see if it could be something we do in FOG - I kind of doubt it but you never know. :-)

    Hope there is someone out there who knows about this and can help you. I can’t, sorry.


 

517
Online

41.9k
Users

12.4k
Topics

116.7k
Posts