Snapin replication no working



  • Snapin replication no working

    FOG VERSION 1.40

    SO: CENTOS7

    #Logs snapin replicate

    [09-16-18 5:23:34 pm] * Attempting to perform Group -> Group snapin replication.
    [09-16-18 5:23:34 pm] | Replicating ssl less private key
    [09-16-18 5:23:34 pm] * Found Snapin to transfer to 35 nodes
    [09-16-18 5:23:34 pm] | File Name: ssl/fog.csr
    [09-16-18 5:23:37 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-001
    [09-16-18 5:23:41 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-002
    [09-16-18 5:23:44 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-003
    [09-16-18 5:23:50 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-004
    [09-16-18 5:23:53 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-005
    [09-16-18 5:23:56 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-006
    [09-16-18 5:24:00 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-007
    [09-16-18 5:24:03 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-008
    [09-16-18 5:24:05 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-009
    [09-16-18 5:24:07 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-010
    [09-16-18 5:24:09 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-011
    [09-16-18 5:24:12 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-012
    [09-16-18 5:24:14 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-013
    [09-16-18 5:24:17 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-014
    [09-16-18 5:24:20 pm] | ssl/fog.csr: No need to sync fog.csr file to ZNE-015```
    
    [root@fog log]# systemctl -l status FOGSnapinReplicator
    ● FOGSnapinReplicator.service - FOGSnapinReplicator
       Loaded: loaded (/usr/lib/systemd/system/FOGSnapinReplicator.service; enabled; vendor preset: disabled)
       Active: active (running) since Dom 2018-09-16 17:11:43 -03; 21min ago
     Main PID: 26173 (FOGSnapinReplic)
       CGroup: /system.slice/FOGSnapinReplicator.service
               ├─26173 /usr/bin/php -q /opt/fog/service/FOGSnapinReplicator/FOGSnapinReplicator &
               └─26181 /usr/bin/php -q /opt/fog/service/FOGSnapinReplicator/FOGSnapinReplicator &
    
    Set 16 17:11:43 fog systemd[1]: Started FOGSnapinReplicator.
    Set 16 17:11:43 fog systemd[1]: Starting FOGSnapinReplicator...```


  • @Quazz said in Snapin replication no working:

    systemctl start FOGSnapinReplicator

    10x dude …that did the trick 🙂 now its all working again


  • Moderator

    @AlexPDX Rule of thumb is to create a new thread, since the OP in this case was using a very old version, and you are likely using FOG 1.5.8

    That said, quick fix is:

    sed -i 's#/usr/bin/php env #/usr/bin/env php #g' /usr/lib/systemd/system/FOGSnapinReplicator.service
    systemctl daemon-reload
    systemctl start FOGSnapinReplicator
    


  • I did’nt knew if i should make a new post or not…but im haveing kind of…the same isuie…
    My Snapin Replication dose not work 😞 …i managed to start my images replication with : systemctl restart FOGImageReplicator ( cent os7 ) and now all is goog …but the same restart did not work for snapin replication 😞 and i get this 😞 :

    code_text
    ```[root@HQ-FOG log]# systemctl status FOGSnapinReplicator
    ● FOGSnapinReplicator.service - FOGSnapinReplicator
       Loaded: loaded (/usr/lib/systemd/system/FOGSnapinReplicator.service; enabled; vendor preset: disabled)
       Active: failed (Result: start-limit) since Tue 2020-02-25 13:13:29 EET; 1h 54min ago
      Process: 20377 ExecStart=/usr/bin/php env /opt/fog/service/FOGSnapinReplicator/FOGSnapinReplicator (code=exited, status=1/FAILURE)
     Main PID: 20377 (code=exited, status=1/FAILURE)
    
    Feb 25 13:13:28 HQ-FOG: Unit FOGSnapinReplicator.service entered failed state.
    Feb 25 13:13:28 HQ-FOG: FOGSnapinReplicator.service failed.
    Feb 25 13:13:29 HQ-FOG: FOGSnapinReplicator.service holdoff time over, scheduling restart.
    Feb 25 13:13:29 HQ-FOG: Stopped FOGSnapinReplicator.
    Feb 25 13:13:29 HQ-FOG: start request repeated too quickly for FOGSnapinReplicator.service
    Feb 25 13:13:29 HQ-FOG: Failed to start FOGSnapinReplicator.
    Feb 25 13:13:29 HQ-FOG: Unit FOGSnapinReplicator.service entered failed state.
    Feb 25 13:13:29 HQ-FOG: FOGSnapinReplicator.service failed.
    
    
    ...now where did i go wrong ?

  • Senior Developer

    @wanderson Sorry for the long deply!! Re-reading your postings I am wondering why you use FOG 1.4.0. This is years old and there have been many changes since.

    We do not have many people working on FOG at the moment and therefore can’t support older versions. If you upgrade to 1.5.4 and still see the same issue we might be able to help you out.

    Don’t get me wrong. If I could see why this is not working I would surely tell you. It’s just too little information and the version gap that I tell you we won’t be able to help just like this.



  • Help-me please



  • help-me please!!!



  • 0_1537132353424_Capturar.PNG



  • 35 storage nodes

    0_1537130717104_Capturar.PNG



  • 0_1537130606901_Capturar.PNG



  • [root@fog fog]# ls -lha
    total 24K
    drwxr-xr-x   5 root root   4,0K Ago  9 18:14 .
    drwxr-xr-x.  6 root root   4,0K Set  6 12:26 ..
    -rw-r--r--   1 root root   1,3K Ago  9 18:14 .fogsettings
    drwxr-xr-x   2 root root   4,0K Set 16 17:11 log
    drwxr-xr-x  11 root root   4,0K Jul 18 16:08 service
    drwxrwxrwx   3 fog  apache 4,0K Set 16 17:09 snapins
    [root@fog fog]#
    

Log in to reply
 

349
Online

7.4k
Users

14.5k
Topics

136.5k
Posts