UNSOLVED CentOS 7 FOG Installation Trouble - MySQL/MariaDB not starting, also Fog services not starting

  • Good morning everyone,

    I’m having trouble installing FOG project so that I may test this solution. From what I gather, the installer is unable to install remi release 7, and start any FOG services, as show in the text dump of my most recent error log below. I also cannot access the fog user on my system. On the log it says no interface with connection to internet, but I am able to fix that during the installation process.

  • @Sebastian-Roth I will give the doc a read through, but I believe it was more or less set up by IT. I plugged in my system to the network by ethernet through an VOIP phone, and gave them the system’s MAC address and then they assigned the box an IP. I do not recall messing with settings other than the systems proxy settings when getting on the network.

  • Senior Developer

    @cag292 Take a look at this: https://www.centos.org/docs/5/html/Deployment_Guide-en-US/s1-networkscripts-interfaces.html

    You don’t want to have BOOTPROTO=dhcp and static IP configuration at the same time. Who did set this server up? Who did the network configuration? Not wanting to blame anyone here, I am just wondering if you got this ready setup by your IT?

  • @Sebastian-Roth I think it could be how our IT set up the IP through our DHCP server. I had to give them the systems MAC address and then they had an new IP generated. Here is the contents of ifcfg-enp5s0

  • Senior Developer

    @cag292 Well that’s an interesting one. You have two IP addresses on one network interface. The two IPs are from overlapping subnets. Are you sure you meant to set it up this way? My guess is that this is causing an issue. Why do you have it this way?

    Can you please share the contents of /etc/sysconfig/network-scripts/ifcfg-enp5s0?

  • @Sebastian-Roth Here are snapshots of the commands.0_1536434852212_ip_a_s_Screenshot.png

  • Senior Developer

    @cag292 said:

    The IP in the screenshot posted is our proxy, which seems to be a wall in trying to install FOG.

    Ahhh, I was wondering about that already. Now Linux and FOG can usually handle proxy. And from what it looks like curl tried to connect to your company’s proxy server but it was not able to. No route to host means that your FOG server is in a different subnet than the proxy server and there is no default gateway set on your FOG server. Please post the output of the following two commands here and we may be able to help with setting up the proxy connection: ip a s and ip r s (in case ip is not installed you should get the same information via ifconfig -a and route -n)

  • @Sebastian-Roth On the point of the simple updates, I do not have the basic/online repositories enabled. Our sys admin had stated he believes that it is a pain to configure CentOS to work with our network, so he had set up an internal repository for the company. Perhaps there are outdated packages and or missing packages?
    I’ve had trouble connecting package updaters/installers such as yum, rpm, and git to the machine through our network. The IP in the screenshot posted is our proxy, which seems to be a wall in trying to install FOG.
    Thank you for your assistance so far though.

  • Senior Developer

    @cag292 Looking at the log I don’t see an issue with MySQL/MariaDB at all. Seems to start just fine. The messages on FOG services can be ignored. This is just because the installer makes sure to stop/shutdown those services in case of an existing installation still running (when upgrading to a later version).

    Now what caught my eye are numerous lines like putting xxx in simple update. Possibly the online repositories are not enabled? See here: https://www.centos.org/forums/viewtopic.php?t=62700

    And even more problematic are those messages:

    curl: (7) Failed connect to; No route to host
    error: skipping http://rpms.remirepo.net/enterprise/remi-release-7.rpm - transfer failed

    You cannot install FOG without an internet connection! Make sure you have a proper connection before running the installer.