Cannot stop FOG capture



  • I noticed while doing a remote capture that the file system was LVM and so the partitions failed to shrink. I canceled the task on the FOG web gui but the remote server continues to try and send the capture. I’ve sent ctrl+alt+del as well as many other commands but partclone will not stop.

    How do I cancel the process on the remote server? I’m using a remote KVM so I don’t have the option to power the server on or off. I can only send keyboard commands. Any suggestions to get this remote server to stop what it’s doing and simply reboot? The remote server is using CentOS 6.6



  • @Sebastian-Roth Ctrl+C doesn’t work either. Yeah we have 35+ sites that have PBX’s on older machines. We are in the middle of a tech refresh right now and and we are replacing them with servers that have ILO’s so this won’t be an issue in the future. For now what I do is ship the site a remote KVM so I can at least perform maintenance without user interaction. It was over the weekend so all site personnel were gone. This issue can be closed now. I had someone just press the power button this morning. I was just trying to find another way over the weekend.


  • Developer

    @kafluke Maybe Ctrl+C would cancel partclone but I am not sure!? FOG is not build to kill a job right in the middle of a running partclone. While I see it would be very helpful in your case it seems like most users have access to the power button and can cancel a running job on the client like that.

    But don’t you have the need to shutdown or reboot the machine in other cases as well? Think about investing some money in powerplugs that can be remote controlled via a IP-based web interface?!



  • @Wayne-Workman Thank you, yes I know you cannot resize LVM partitions. I failed to pre-check the file system before starting the capture. When I noticed the capture size I canceled the task in the gui but the process continues on the remote machine. I’m trying to reboot but sending ctrl+alt+delete does nothing. This is an IP based external (not idrac or sp) KVM. It only has USB keyboard input and VGA capture. There are no power or reboot options in the console because its keyboard and mouse input only.

    That’s why I’m asking the question, what key combo can I use to stop the partclone process? I could reboot from cli but I cant seem to exit partclone.



  • @kafluke said in Cannot stop FOG capture:

    How do I cancel the process on the remote server?

    FOG does not support resizable LVM partitions. The only way to stop it at this point is to reboot. KVM should allow you to force-stop the machine.


Log in to reply
 

512
Online

5.8k
Users

13.1k
Topics

123.1k
Posts