Could not complete tasking (/bin/fog.upload)

  • I just got my Fog server up and running on Fedora Server 28 and while attempting to capture my first image everything appeared to be going well until the very end when I got the error
    “Could not complete tasking (/bin/fog.upload)”


    “Error returned: Type: 8, File: /var/www/html/fog/lib/fog/fogcontroller.class.php, Line: 975, Message: Undefined offset: 3, Host:, Username: fog”

    I searched the forums and found a couple of posts with the same error, but it doesn’t looks like my error is caused by the same thing. I know you can receive this error if the password for the fog user gets changed in some places, but I haven’t touched that password. This is from a fresh install and the password matches everywhere.

    I also took a look at /var/www/html/fog/lib/fog/fogcontroller.class.php on my server. I don’t see any glaring issues in there, but then again, I don’t know what I’m looking for.

    Could there be something else causing this error?

  • I decided to go ahead and start all over with CentOS7 instead of Fedora this time. I setup the server as well as Fog the same exact way. This time I didn’t run into any issues with the Fog server’s firewall like I did on the Fedora server. And I was able to successfully capture an image from my test laptop with no errors.

    I’m running another test right now with deploying the image to the laptop to make sure there’s no issues there, but it looks like switching to CentOS worked for me.

    I know the most recent wiki on installing fog on Fedora is specifically for Fedora 25 so maybe a lot has changed between Fedora 25 and Fedora 28 that the same instructions won’t work, but I’m just guessing.

  • @george1421 No problem. Thanks for looking.

  • Moderator

    @Zerpie I personally would use centos. But let me look at the code tonight to make sure before you build a new FOG server.

  • @george1421 I think I’m going to go ahead and do a fresh install of the OS again tomorrow. Maybe Fedora Server isn’t the way to go. Is there a recommended Linux distro I should use instead?

  • Moderator

    @Zerpie While I’m not a programmer, I guess I need to look at that specific line and see if I can identify why this issue is only impacting you. Considering that you reinstalled FOG again and have the same issue (my inner voice is saying that its something you are doing or something that the FOG UI is allowing you to do). That’s not to say you are specifically doing something wrong, but its more unique to your install.

  • Everything about my issue is still pointing to credentials not matching, but I’ve gone through the troubleshooting for that over, and over, and over again. Fresh installs and all. What else can I do? I never touched the credentials in the first place!

  • @george1421 Sorry, George. I had to go ahead and try and run an image capture task again to see specifically what it was doing. I receive the error when it attempts to update the database. It shows

    Error returned: Type: 8, File: /var/www/html/fog/lib/fog/fogcontroller.class.php, Line: 975, Message: Undefined offset: 3, Host:, Username: fog

  • I have a feeling there might be a permissions issue with /bin/fog.upload, but I can’t find fog.upload anywhere in /bin/.

  • @Zerpie Based on the error message I checked /var/www/html/fog/lib/fog/fogcontroller.class.php line 975 and the line is

    if ($fields[3]) {
                   	array_walk($fields[3], $whereInfo);

    Anybody have any clue what that means?

  • @george1421 It was finishing up capturing an image from a host. Other than that error at the end, it looked like it finished capturing the image. Then I got the error and the host machine rebooted. The task still shows that it’s running and is sitting at 97%.

  • Moderator

    @Zerpie said in Could not complete tasking (/bin/fog.upload):

    “Error returned: Type: 8, File: /var/www/html/fog/lib/fog/fogcontroller.class.php, Line: 975, Message: Undefined offset: 3, Host:, Username: fog”

    What was fog doing when it threw this error?

  • @george1421 I did indeed hit all of those sections. The tftp settings is the only place that had the wrong password.

    It doesn’t appear to be multicasting. When I go to Tasks > Active Multicast Tasks it does not show my capture task.

  • Moderator

    @Zerpie Did you hit all of the spots mentioned in this document?

    The undefined offset is a bit strange though. the error makes me thing you were multicasting when this happened?

    Are you running FOG version 1.5.4? If so did you / have you updated www.conf file?

  • Unfortunately this did not fix it. I ended up with the exact same error.

  • Update: I just went back through and checked all the places where the fog password is set and somehow the tftp settings in the Web interface was a different password. I set it to the same password that was in /opt/fog/.fogsettings.

    Now I’m trying to capture the image again. Hopefully that’s all it was. I’ll give another update if it was successful or not.

Log in to reply