Upgrade to 1.5.4



  • Hello,
    I’m trying to upgrade from 1.5.2 to 1.5.4 to address some issues we’ve been having deploying and capturing images. When i try to run the installer, it seems to go fine until it gets to here:

    • Confirming package installation

    • Checking package: apache2…OK

    • Checking package: bc…OK

    • Checking package: build-essential…OK

    • Checking package: cpp…OK

    • Checking package: curl…Failed!

    At that point it quits out. The web GUI still shows version 1.5.2 is active. I have installed curl separately and that has not seemed to make a difference.

    If I should just be making tickets about the other issues before upgrading, please let me know.



  • Ok, the file is pretty big, so if you want i can upload the whole thing. That said, this is what i picked out from it:


    The following packages will be REMOVED:
    curl libcurl4 php7.1-curl
    The following NEW packages will be installed:
    libcurl13


    The following additional packages will be installed:
    libcurl4
    The following packages will be REMOVED:
    libcurl3
    The following NEW packages will be installed:
    libcurl4 php7.1-curl
    0 upgraded, 2 newly installed, 1 to remove and 145 not upgraded.


    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libcurl3 : Conflicts: libcurl4 but 7.58.0-2ubuntu3.2 is to be installed
    libcurl4 : Conflicts: libcurl3 but 7.58.0-2ubuntu2 is to be installed
    E: Broken packages
    ii apache2 2.4.33-1+ubuntu17.10.1+deb.sury.org+1 amd64 Apache HTTP Server
    ii bc 1.07.1-2 amd64 GNU bc arbitrary precision calculator language
    ii build-essential 12.4ubuntu1 amd64 Informational list of build-essential packages
    ii cpp 4:7.3.0-3ubuntu2 amd64 GNU C preprocessor (cpp)


    So, maybe i have too new a version of curl installed? I’m not sure how that would happen, we don’t use this server for anything but fog. Would that cause the installer to fail this way?


  • Moderator

    @cklemm In the same directory as the fog installer, should be an error log directory. In there you should find a 1.5.4 upgrade log. See if that tells us a bit more information about what it didn’t like about curl.



  • I’m running Ubuntu 18.04.



  • @cklemm This is strange. What OS & version are you using?


Log in to reply
 

335
Online

6.0k
Users

13.4k
Topics

126.2k
Posts