Site plugin and 1.5



  • Hi everyone !

    I’m using FOG 1.4 with site plugin and it’s work fine. But last week i try to upgrade to 1.5 and this plugin seems to have a problem.
    I can’t change a host location from the host page, if i select new location i can’t save. But it’s work from the site plugin page. When i restore my server with FOG 1.4 the site plugin work fine with host page.

    Thanks.


  • Developer

    @Aur3l I am wondering if this was ever solved. If this is still an issue with current FOG 1.5.5 I will have a look and try to fix it.



  • I try with an update from 1.4.4 to 1.5.4 and install from scratch, same problem.
    After changing Host Site and clicking “update” nothing append (no message ‘host updated !’) and apache error log says :

    [Thu Aug 23 11:25:30.658913 2018] [proxy_fcgi:error] [pid 50898] [client x.x.x.x:x] AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught Error: Call to a member function get() on null in /var/www/fog/lib/plugins/site/hooks/addsitehost.hook.php:322\nStack trace:\n#0 /var/www/fog/lib/fog/hookmanager.class.php(87): AddSiteHost->hostAddSite(Array)\n#1 /var/www/fog/lib/pages/hostmanagementpage.class.php(3701): HookManager->processEvent('HOST_EDIT_SUCCE...', Array)\n#2 /var/www/fog/lib/fog/fogpagemanager.class.php(220): HostManagementPage->editPost()\n#3 /var/www/fog/management/index.php(54): FOGPageManager->render()\n#4 {main}\n  thrown in /var/www/fog/lib/plugins/site/hooks/addsitehost.hook.php on line 322\n', referer: http://x.x.x.x/fog/management/index.php?node=host&sub=edit&id=1
    

    Then Javascript Console says when i click ‘Update’ :

    jquery-latest.min.js?ver=133:4 POST http://x.x.x.x/fog/management/index.php?node=host&sub=edit&id=1&tab=host-general 500 (Internal Server Error)
    send	@	jquery-latest.min.js?ver=133:4
    ajax	@	jquery-latest.min.js?ver=133:4
    a.ajax	@	jquery-migrate-latest.min.js?ver=133:2
    submithandlerfunc	@	fog.js?ver=133:601
    d	@	jquery.validate.min.js?ver=133:4
    (anonymous)	@	jquery.validate.min.js?ver=133:4
    dispatch	@	jquery-latest.min.js?ver=133:3
    q.handle	@	jquery-latest.min.js?ver=133:3
    

    If i don’t select any host and do an update the message “Host updated !” appears by the way.


  • Senior Developer

    Are you really updating to 1.5 or 1.5.4? 1.5.0 I believe had issues with plugins (if I’m to remember correctly, but am pretty sure this has since been fixed.) The problem, truly, was with all Plugins, as it wouldn’t create the database needed for the plugin when it was installed.

    Can you get us more information and possibly provide the apache error logs when you attempt to do something? (Debian = /var/log/apache2/error.log, Redhat = /var/log/httpd/error_log)

    Can you also get the browser’s Javascript Console when you attempt to do an action? (On chrome press the keys CTRL+SHIFT+C and click the console tab).


 

414
Online

5.4k
Users

12.6k
Topics

118.9k
Posts