Fog tftp only works when I disable firewalld

  • I’ve been going crazy trying to solve this problem.
    I’m not a Linux guy so I’m making sure to follow all the directions on the wiki as close as possible as to not screw this all up.
    I’m running Fog in Fedora 28.

    I’ve gone through all the steps in… and I’ve at least been able to narrow the problem down to firewalld.
    I’m using a Windows 10 machine to test tftp
    running tftp -i x.x.x.x get undionly.kpxe
    and it works only when I disable firewalld on the Fog server.

    I’ve configured it as per multiple times and even done a couple of complete Fedora and then Fog reinstalls and I still end up with the same issue.

    Is there something that needs to be done differently specifically for Fedora 28?

  • @Wayne-Workman said in Fog tftp only works when I disable firewalld:


    Turns out this time around it was me not entering the correct info during the install. Wrong router address for the DHCP server and wrong address entered on the DHCP server for option 66. When I ran the installer again this morning I realized what I did wrong right away. So far so good right now…

  • @zerpie Check SELinux: sestatus Also, see if turning the firewall off resolves it.

  • And it looks like I’ve run into my first new issue on a fresh install. I’ve just run the Fog installer and got to the bit to install/update the database schema, but I am unable to reach the web interface. Not sure where to go from here.

  • @tom-elliott You’re right, I should have come to the forums much earlier when I started having trouble. The good news is that even though I was frustrated and ready to give up on Fog yesterday, today I’m feeling much more optimistic and I’m still working on getting Fog up and running.

    Previously I’ve been installing Fedora and Fog onto a physical machine and trying to run it over an isolated LAN using the built-in DHCP server just to see if I can get it up and running and play around with it to see if it’ll do everything I want it to do. Since that giving me trouble, I’ve gone ahead and spun up a Fedora VM and I’m going to try and integrate Fog into my existing Windows DHCP server. Maybe this different approach will yield better results. I’ll definitely make sure to come here to get help from the community if I run into any other issues moving forward.

  • Senior Developer

    I understand your frustration and sorry you’ve had such a hard time getting things up and running. That said, you’ve only posted informing us that you even had a problem 5 days ago. I am certain we can help get this running but we need information as to the things you’ve tried, the exact messages you’re seeing, etc…

    If you feel you must use another product, then I understand, but if you’re having this many issues with FOG, chances are likely that you’ll have similar issues using another product. Clonezilla, SCCM, MDT/WDS, etc… will have similar methods each with their own pros and cons.

    As you said you’ve been working on this for 3 weeks, but from allowing us to help you we’ve only had 5 days (and 2 of them were a weekend.) I’m not sure how much you expect us to be able to help.

    Can you provide more direct error messages? I’m not quite sure what error you’re referring too with the “Could not complete tasking” as it should provide more information. From the sounds of things, FTP is either not running, or something else is blocking FTP altogether. I don’t know.

    3 Messages and you’re ready to give up seems a bit rash to me. Then again, I do understand your frustration. I just don’t know how you expected us to get you running with so little information and back and forth between the Senior Developer of FOG and our community.

  • @zerpie said in Fog tftp only works when I disable firewalld:

    I’m afraid that at this point I’ve spent way too much time trying to even get Fog to work at all that I’m going to need to look for another imaging solution.

    That is unfortunate. Best of luck to you.

  • @tom-elliott I have tried that, but still running into the same problem. I’ve tried continuing with the firewall disabled, but then of course I run into a new issue when capturing an image.

    “Could not complete tasking (/bin/fog.upload)”
    Which looks to typically be a problem if you mess with the fog user’s password, which I had not. Either way I checked all areas where that fog user and pass live and made sure the password was matching, but it’s still continuing.

    I’m afraid that at this point I’ve spent way too much time trying to even get Fog to work at all that I’m going to need to look for another imaging solution. It seemed promising thought based on the reviews I’ve read, but I’ve been working on this for 3 weeks straight and I haven’t even gotten to the point where I can capture and deploy images.

  • Senior Developer

    Have you tried this?

    (Fedora = Redhat = CentOS).

    Please pay particular attention to the permanent as that means it will remain every reboot.

    Another method would be to simply disable firewalld altogether but I understand wanting to keep it enabled.

    Another thing you may need to look into is ensuring selinux is allowing TFTP. (You can test by running sudo setenforce 0) My guess is SELinux is biting you right now which is why nothing you’re following seems to be “sticking” yet.

  • @wayne-workman Thanks, Wayne. I have followed along with the Fedora 25 Server article you linked. I even did a fresh install this morning while following along to that exact article, but I’m still running into the exact same issue.

  • @zerpie Those firewalld rules in that article were out of date, I just updated them. Have you tried following along with this:
    Yes, I know it’s for Fedora 25 but honestly the steps for Fedora 21 to 28 are pretty much identical.