Issue Imaging HP EliteDesk 800 G3



  • I am able to capture the image for the HP EliteDesk 800 G3 but when I try to restore it fails to boot. The message I receive is BootDevice Not Found. Please install an operating system on your hard disk. Hard Disk - (3F0)

    I’ve downloaded the latest version of FOG but it hasn’t resolved the issue. Any help would be appreciated.



  • @Wayne-Workman

    Tried a totally different, but exactly the same, box and the master image worked for capturing and deploying. Very strange but whatever. I’ll take it.

    Thanks!



  • @phishphan Well that’s a pretty good sign. Hope it works out.



  • @wayne-workman

    Recent development. I pulled a master image from a different computer and tried that. I’ve had one successful deployment. Going to test another on Monday. Will update then. Thanks!



  • @phishphan said in Issue Imaging HP EliteDesk 800 G3:

    On the machine that is working I have a boot option under UEFI that says M.2 Windows Boot Manager which does not exist on the machines that I’m attempting to image. I’m still getting the operating system not found on those.

    This is interesting. What do you mean the other does not have this setting? Is it simply not available to choose, or is it there but not enabled? Can you post a photo?



  • @sebastian-roth

    Here’s what I’ve found. I recaptured the image from the master. I was able to re-image the master machine with the capture and it worked. Then I tried a totally different computer and it didn’t work. These are all factory new HP’s out of the box.

    Now, something I noticed different in the BIOS. On the machine that is working I have a boot option under UEFI that says M.2 Windows Boot Manager which does not exist on the machines that I’m attempting to image. I’m still getting the operating system not found on those.


  • Developer

    @phishphan said in Issue Imaging HP EliteDesk 800 G3:

    I currently have the partition set to Singe Disk - Resizeable but I’ve also tried Multiple Part Single Not Resizeable without any success.

    When switching to non-resize, did you re-capture the image from your master machine? You need to!

    Your partition layout is preventing FOG from being able to properly resize as the third partitions seems to be the recovery part which we don’t want to move as it could break recovery.

    Are you saying that you deploy the image to the very same machine or is it another one from the same model? Compared all BIOS settings? Same BIOS firmware version?



  • @SEBASTIAN ROTH thank you kindly for your reply. Please find the requested information below.

    I am on version 1.5.4

    I currently have the partition set to Singe Disk - Resizeable but I’ve also tried Multiple Part Single Not Resizeable without any success.

    The OS is correctly set to Windows 10

    No errors are received on deploying the image. It simply reboots and comes back to the boot device not found screen.

    Please note that this workstation uses an NVMe SSD. The only change I’ve made in BIOS is to allow LEGACY PXE booting.

    CONTENTS

    d1.fixed_size_partitions
    :1:3

    d1.minimum.partitions
    label: gpt
    label-id: 4251A099-FB23-4AA7-8DE7-0FB9F64FBBD8
    device: /dev/nvme0n1
    unit: sectors
    first-lba: 34
    last-lba: 1000215182

    /dev/nvme0n1p1 : start= 2048, size= 2072576, type=C12A7328-F81F-11D2-BA4B-00A0C93EC93B, uuid=9C48635D-51CD-4F39-94B1-92BE6906A844
    /dev/nvme0n1p2 : start= 2074624, size= 377257624, type=EBD0A0A2-B9E5-4433-87C0-68B6B72699C7, uuid=54FE51CA-67BE-4800-8050-F48BE37C6938
    /dev/nvme0n1p3 : start= 999951024, size= 262144, type=E3C9E316-0B5C-4DB8-817D-F92DF00215AE, uuid=434727C3-71FF-4950-898F-F6AAC7DDEA69

    d1.partitions
    label: gpt
    label-id: 4251A099-FB23-4AA7-8DE7-0FB9F64FBBD8
    device: /dev/nvme0n1
    unit: sectors
    first-lba: 34
    last-lba: 1000215182

    /dev/nvme0n1p1 : start= 2048, size= 2072576, type=C12A7328-F81F-11D2-BA4B-00A0C93EC93B, uuid=9C48635D-51CD-4F39-94B1-92BE6906A844
    /dev/nvme0n1p2 : start= 2074624, size= 997876400, type=EBD0A0A2-B9E5-4433-87C0-68B6B72699C7, uuid=54FE51CA-67BE-4800-8050-F48BE37C6938
    /dev/nvme0n1p3 : start= 999951024, size= 262144, type=E3C9E316-0B5C-4DB8-817D-F92DF00215AE, uuid=434727C3-71FF-4950-898F-F6AAC7DDEA69


  • Developer

    @phishphan Allow me a couple more questions:

    • Which version do you mean by the latest - 1.5.4?
    • Is the image set to resizable or non-resizable? Was this changed between capture and restore?
    • What Windows version is this? Properly set in the image settings?
    • Do you get any errors when restoring the image to the machine?

    Please post the contents of d1.fixed_size_partitions, d1.minimum.partitions and d1.partitions which you find in the image directory on your FOG server (usually /images/…).


Log in to reply
 

575
Online

5.8k
Users

13.1k
Topics

123.2k
Posts