Went from FOG w/2 NICs (one DHCP, one not) to 1 - snapins, permissions, errors...



  • I’ve moved my fog server from a machine with 2 NIC cards, one of which was a static IP address (10.2.2.1) running dhcp, etc for booting. The other was a DHCP client using a reserved IP (172.16.x.x) to connect up to client machines for snapins and such.

    I’d boot to a local network, get a 10.2.2.x address, register in fog, deploy image, reboot client machine, in my post setup install a wifi profile, install fog to the dhcp client (172.16.x.x) to receive snapins.

    I’ve now migrated to using only one network card.

    I changed the network card settings to DHCP from static, i re-ran the installer, which didn’t work the first time so I renamed the .fogsettings file and reinstalled. maybe this is how I broke it.

    Now so far, I’ve had to change the IP in tftp and in pxe boot menu settings, which finally ended up working, but my permissions seem to be off or something. snapins register as the wrong hash, according to the client, and recreating them as a new snapin say no hash exists…I didnt know if the hash was built off of the IP, or what, but I’m stuck.



  • @wayne-workman that was basically it. worked extraordinarily well with the one. my initial setup and testing, i didn’t have control over the dhcp server so i had to do it with two. it worked at that site, but there were flaws. once deploying it, a mix of hardware issues, network issues, and ultimately permissions on things caused problems.
    thanks for all you guys do though.



  • Yeah using multiple NICs with fog requires some Linux savyness and some network knowledge. Using it with one NIC - you just need to follow pre-written directions and the installer can setup what you need.



  • @wayne-workman 1.5.4.

    ultimately i’ve had a crapton of problems with fog - but now I realize why. Its terrible (at least how I’ve tried to set it up) with multiple nics…and terribly easy to set it up with option 66/67. You guys can all disregard this issue - I threw a VM of it on an esx server with one virtual nic, and fog and linux are the most stable i’ve had it yet.

    thanks though.


  • Senior Developer

    @wayne-workman http I believe, where possible. I can’t remember been a while since I looked at the codebase. I’ll get back to you on it.



  • @p4cm4n said in Went from FOG w/2 NICs (one DHCP, one not) to 1 - snapins, permissions, errors...:

    snapins register as the wrong hash, according to the client

    @developers does the snapin upload process use HTTP post or a vsftp transfer?

    @p4cm4n What version of FOG are you using?


Log in to reply
 

447
Online

6.2k
Users

13.6k
Topics

128.0k
Posts